Video Stuttering Caused by Freesync

Description of issue:

Freesync causes video stuttering when video is in fullscreen for videos that offer high frame rate (60 FPS)

How can this issue be reproduce?

  1. Open up Brave.
  2. Go to YouTube.
  3. Click on any video that offers 60FPS playback.
  4. Click on the fullscreen icon and wait for the video playback bar to disappear.
  5. Video begins to stutter.

Expected result:

Smooth playback on YouTube video with high framerate (60FPS).

Brave Version( check About Brave):

v1.47.171

Additional Information:

Edit: Included system specs.
Edit 2: Included GPU driver version.
Edit 3: Turning off hardware acceleration or enabling Vulkan does not resolve the issue.

Specs:
GPU: AMD 5700XT, driver version 22.11.2
CPU: AMD 3700X
RAM: 16GB
Storage: 480GB SSD boot drive, 2TB hard drive
Monitor: AOC 24G1WG4 144HZ
OS: Windows 10 Home 64bit

Current workaround:

  1. Open up AMD’s GPU control panel (adrenaline software).
  2. Click on the “Gaming” tab.
  3. Click on the 3 dots at the top and select “add game”.
  4. locate the directory of where Brave is installed at (this can be done by right clicking on the Brave shortcut and clicking on “Open file location”.
  5. Copy and paste the directory that you see at the top of file explorer.
  6. Paste that into the File explorer AMD popped up and hit Enter.
  7. Click on Brave.exe.
  8. Brave should now be added to the list of “games” in your AMD control panel.
  9. Click on Brave in your AMD control panel.
  10. Click on AMD Freesync and select “off”.

You should now experience stutter free videos on fullscreen playback. The problem with this workaround is that you won’t be able to configure game settings in the AMD control panel when Brave is opened. The other solution would be to disable Freesync globally, but that will disable Freesync for games or any other application as well.

I’ve seen this bug reported only a few times throughout the years, but it seems like there hasn’t been any developments in that issue. I think that this can cause some new Brave users to try out the browser, but notice that there are video playback stuttering and turn away from using the browser. Curiously, this doesn’t seem to affect some other chromium based browsers such as Chrome and Opera. I suspect that the AMD team needs to whitelist the browser to not trigger Freesync, but I’m not too sure if this is the case.

@striderstroke Just wanted to offer two potential suggestions. The one was from another User a while ago, who shared post below (with same AMD as you as well):

And yeah, above doesn’t really sound like a solution even though they called it a fix. But not sure if it’s a bread crumb for you or others on how to possibly navigate around the situation.

The other, if that doesn’t work, is my own curiosity if you might see any improvements if you go to brave://flags and enable Vulkan. I’m hesitant will make sudden improvement but it’s just a random thought in case.

Thanks for your reply. I did see that post, but the steps weren’t a good workaround for my case, so I had to disable Freesync specifically for Brave in my GPU control panel. I tried enabling Vulkan, but the videos didn’t load at all and was causing things to render improperly.