Frames Dropped on Youtube with AMD? I finally found the fix

There has been a problem with Youtube dropping frames while watching videos on Youtube since around 2018. I have spent about a year trying to figure this out. For me, it turned out to be a very simple fix. I’m using Windows 10. I’m using a 4k screen at 60 Hz (according to what Win10 says). I’m using an AMD 5700 XT graphics card.

Step 1: Go to this website to test your actual refresh rate:

Step 2: After going to the website above in Brave, then click the Windows Start button and type in Display and click on Change The Resolution Of The Display
On the window that pops up, look at the bottom and click on Advanced display settings.

Step 3: If you’ve gone to the website above FIRST then in Advanced display settings you should NOW be able to change the refresh rate to 59.940 Hz. Just changing this reduced the frame drops on Youtube down to about 1 out of 1000 frames. Note that I couldn’t choose 59.940 Hz unless I went to the website above FIRST on Brave browser.

Step 4: In the lower right side of the Windows Taskbar click the ^ (right next to the volume control) and double click AMD Software Adrenaline Addition to bring up the settings for your AMD card.

Step 5: Click “Graphics” in the AMD settings and enable Radeon anti-lag. If you have a monitor that is compatible with AMD Freesync then ALSO enable that setting.

Step 6: Go back to Youtube and see if you get any dropped frames.

I was getting MANY dropped frames especially on Youtube before this for about the last 3 years. Enough to where it would make pops and glitches when I would try to watch a video on Youtube at ANY resolution from 4k down to 480P.

Now I have been playing a video on Youtube for about 21 minutes and I had only dropped 10 frames out of 5000 at that point in the video.

Sure, it isn’t ZERO dropped frames, but if I’m only losing about 10 out of 5000 frames, it was MUCH better than the up to 500 frames dropped out of 5000 that I had before!

I hope this helps others FINALLY solve this issue.


@MnM ,

Good work. Thanks.

@Chocoholic - another fix for your collection of solutions.


I’m glad it worked for someone else. Now the whole world needs to know!

This topic was automatically closed after 30 days. New replies are no longer allowed.