A potential fix for the video stuttering in fullscreen for AMD GPU and Freesync users with HA enabled

Hello everyone,

First, my apologies if this is the wrong place to post this, but I had to do it asap and this category seemed more fitting.

Now, a bit of info on my type of case before I proceed with the solution that worked for me:

Ever since I started using Brave a few years ago, I’ve always had issues with stuttering video playback on an AMD GPU when in Fullscreen with Freesync and Hardware Acceleration enabled. The issue is beyond obvious when you exit and enter Fullscreen.

I’ve also noticed that quite a lot of people across the net are still experiencing the problem and are forcing themselves to disable Hardware Acceleration, which really is a waste not to use it, especially if you are on a high-end GPU. The other thing I noticed is that the web is full of workarounds for this problem, but not one single solution that doesn’t sacrifice anything in the process.

Unfortunately, disabling HA on my end really degrades the browsing experience across websites, specifically the heavy ones, and it provides only a slight improvement on the video playback, but the core problem remains. GPU is RX 6800 XT, if you’re interested.

After looking for a solution for the # time, I stumbled upon a lonely reddit post in r/brave_browser and the user stated something that immediately gave me an idea:

Only fix I know of is If I disable my FreeSync in Adrenalin or set my refresh rate to 60hz.
based on my monitor OSD Refresh Rate, it seems that my refresh rate keeps jumping around trying to sync with the youtube video at 60fps.
(Which is exactly how the technology works.)

I then remembered that you can actually control Brave through the AMD drivers if you add it in the Games list. So, to get the best experience without compromise, here’s what you need to do:

  1. Enable Variable Refresh Rate in the Windows settings → Graphics Settings (type it in the start menu), enable Freesync on your display through the AMD drivers → Gaming → Display and lastly enable Hardware Acceleration in Brave.
  • VRR should allow us consistent function of Freesync on the entire system.
  1. Open AMD Adrenalin with right click on the desktop → AMD Adrenalin or double-click the AMD icon in the system tray (bottom right of your screen), or open Start and type “Adrenalin” to find it.

  2. On the 2023 AMD drivers - navigate to the “Gaming” tab → Games → click on the 3 vertical dots at the top right of the list of games → Add a game. The correct Brave executable should be located in:

C:\Program Files\BraveSoftware\Brave-Browser\Application\

  1. After that, “brave” should appear in the list of games - click on it to open the settings and:
  • Set Freesync to “Off”, not “AMD Optimized” as it always acts as “On” for this browser in this case.
  • (not a must, but I recommend it) Expand “Advanced” in the bottom left corner and set the default values, not the ones enforced by AMD → Tessellation - UseApplicationDefault | Surface Format - Disabled | Basically everything should be “Disabled” or “Standard”.
  • Close the browser and open it again to test video playback in Fullscreen with Hardware Acceleration on.

With that, at least on my end, videos in Fullscreen no longer stutter and everything responds much smoother. Freesync only switches off while Brave is on focus and thus it doesn’t interfere with the framerate of the videos, eliminating the stutter. Hardware Acceleration remains enabled and improves the smoothness and stability when browsing.

Now that I think about it, I guess this guide could be applied to any browser.

I really hope I didn’t write all this in vain and it helps other AMD folks with this issue.

Cheers!

This topic was automatically closed after 30 days. New replies are no longer allowed.