Videos stuttering

Description of the issue:

videos seem to skip frames resulting in a very annoying stutter…audio is not affected tho. it happens on all websites that have video playback such as : youtube, twitter, facebook , daily motion , netflix etc.

How can this issue be reproduced?

I dont know how to reproduce it. it seems to happen at random. sometime it goes away when i close the browser and open it and sometimes it doesnt. sometimes it is fixed by changing the quality and sometimes not… i have tried to turn hardware acceleration off but it doesnt work , turning off vulkan and playing with drivers and such but still nothing works

Expected result:

a video playing smothly with no stutter

Brave Version( check About Brave):

Version 1.47.171 Chromium: 109.0.5414.87 (Official Build) (64-bit)

Additional Information:
note: i encountered this issue in the last version before the most recent ubdate but it was fixed quickly by turning off the hardware acceleration but now nothing works and it is starting to frustrate me and thanks in advance to anyone that will try to help

Thanks for reaching out.
Could potentially be an extension installed causing the conflict — do you have any installed at this time? If so, can you try disabling them and test again to see if this makes any difference?

1 Like

i dont have any extentions

Do you use Freesync by any chance? I’ve had issues with video stuttering as well. Turning off Freesync in my GPU control panel for Brave was the workaround that I’ve used for that issue.


Also interested to know if disabling free-sync has any effect on the behavior.

1 Like

Try re-enabling HW Acceleration, also then test the video private window mode (or a new Brave profile)

HW Acceration = off, pushes the CPU more, esp on video playback.

sooo turning free-sync off didn’t do anything at first but after I re-enabled Hardware acceleration, the problem was solved…it has been two days since I last saw a stutter. sooo i will take that as a success…though I am not very fond of the fact that i have to have HW on i would personally be more comfortavble with it off.

TLDR: for anyone in the future that has the same problem: turn off freesync, then turn on Hardware acceleration from brave’s settings.

special thanks to Mattches and striderstroke for the help :heartbeat:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.