URL's won't open sometimes, need to try again

Description of the issue:
Hello guys, I love this browser but I always had this problem I couldn’t solve, this been happening since the begging I think. I just clear all my cookies but the same thing happens.
Whenever I try to google search though the url bar, it shows the output URL and then stops, it won’t go through google but instead it will drop out the link and take me to the new tab page, where it says how many ads the browser saved me etc.

This also happens when I copy-paste URLs, doesn’t happen all the time but often.
If I try again I usually go through in the second or third try.

How can this issue be reproduced?

  1. Google search throught URL Bar
  2. Copy-Pasting a link

Expected result:

Brave Version( check About Brave): 1.31.88

Additional Information: Windows 10, been having that problem for a year.

Hello – do you happen to have Chrome installed? If so, does the same thing happen there?

What about extensions, if you have any installed, can you try disabling them?

If you need to go further than that, I would also try in a Private window, and in a new profile.

It sounds an awful lot like some behavior we’ve seen reported earlier that was from a malicious extension or local proxy. (The Chrome vs. Brave question is intended to try ferreting out the latter.)

1 Like

Hello, tried disabling all my extensions, didn’t work.
Tried private window, didn’t work.
Tried a new profile, didn’t work → my 3rd search on search.brave.com didn’t go through and just opened the new tab page.

Google chrome google search is a lot faster, and I’ve just tried googling on 30 windows and none of them stopped. Uhhh…

I made a video, new profile on brave, 3 tries, one failed…
Chrome going smooth.

Hard to tell with the clicking around in the video, was Enter definitely pressed on that 2nd tab (I think that’s the one that you’re saying failed)? Also, looks like using Brave Search in that instance I believe, but the same thing happens if you use Google? Just looking to make sure I understand the situation.

Are you using any of the ‘Secure DNS’ settings at all in Brave?

Secure DNS in my main profile is activated.

On the test profile that I now created for the video it is not, I’ve changed to google and look at the results.
2nd tab did the same thing, enter is pressed as it showed the google results url for a sec, and it’s too slow compared to chrome.