Brave desktop browser ( latest stable version) not allowing google search to work normally

Description of the issue:

Whenever i search anything with google set as my search engine, it shows that the site isn’t secure enough, and doesn’t allow me to complete a search.

How can this issue be reproduced?

1.Set Google as search engine
2. Search anything

Expected result: google search results will appear

Brave Version( check About Brave): 1.26.74

Additional Information:

Have you tried clearing cache/cookies for Google? Or maybe it’s caused by one of your extension (if you have extension installed).

Well i have amazon assistant and honey installed. Also, it occurs at random times. After changing the search engine from brave search beta to google, it works for some time, and then screws up again. Clearing the cache doesn’t fix this. Is it my extensions? Also, i get this only with google, not with any other engine

Plz click the Advanced button and tell us what it says underneath.

This is what pops up when i search with google.

Something is trying to intercept your connection to Google.

Could be a malicious browser extension, or something on a Wi-Fi network (if you’re in a hotel for example), a business’s web proxy (if you’re on their network), or something else on your computer.

First thing I would do is disable all your extensions for a while and see if the problem goes away.

Well, im on my home network, and ive already checked all clients, nothing unknown is connected. I’ll try disabling the extensions.
Edit: removing extensions doesnt work

Do you mean you couldn’t disable the extensions, or that disabling them didn’t help?

Do you have any other browsers you can test with, and see if the behavior follows the browser vs. the PC?

We may be getting beyond the scope of this being a ‘Brave’ issue but we’ll see where this goes next.

Disabling them didn’t fix it.
Somehow, im getting the same issue on chrome and edge too. Is it some kinda chromium bug?

If its showing it on all Browsers, I think something is wrong…

Try running an antivirus test, Hopefully fixes it…

Sure, ill run a scan, just in case

1 Like

Might be related to the forcing of secure HTTPS connections.

If you venture into the following, there are risks that you might screw up — so write down careful notes about your every step. Be familiar with the instructions, first.

Info to study at

How to clear HSTS settings (in most popular browsers):

Example of something similar to what you have encountered:

Unfortunately, some HSTS settings can inadvertently cause browser errors. For instance, if you’re using Chrome, you might run into:

Privacy error: Your connection is not private

If / when you dare to venture - at your own risk:

Where the (how to clear) instructions mention, for example:


in the following line:

  1. Navigate to chrome://net-internals/#hsts

Using your Brave Browser, you would instead “Navigate to”:


There, are two sections re the instructions:



1 Like

I ran a scan with malwarebytes, and some software file inside the windows folder was supposedly named “proxyenable” or something like that. Once i deleted it, the google search is working normally for now.

1 Like

OK. Good.

Here are some things I found which seem similar. Very likely was related to some kind of malware – which could still be there and just temporarily neutered, hard to say."proxyenable"+malware+google&source=web

BTW, MS Defender also has an offline scan you can run. Since you likely already have this on your system, may as well use it also:

1 Like

Good its fixed now. :slight_smile:

Yeah, thanks. It turned out to be some kinda proxy enabler. I think that for malware other than viruses, trojans etc, for eg. Unwanted programs that won’t uninstall, or trojans and stuff, malwarebytes is the best. It has saved me before, when some shady toolbar installed itself into my chrome browser, due to some shady freeware. Its a lifesaver.

Also for the malware, i ran a full system scan via bitdefender, and it deleted 2 files that were supected to be malware. One of them was in the windows folder, so it had to do a preeboot scan. I think whatever was causing this is now gone for good.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.