Ridirecting error since last update

Hi.

Since my Brave (Windows 11) last updated on 4 April, I keep getting a redirect error when clicking a retailer from a Google search. It stays on screen for about 2 seconds then successfully goes to the right website.

Does this happen to anyone else?

@deeky6 ,

Given that I prefer using the (Brave Browser for desktops) New Private Window . . . some time in March (February?), the problem began:

If I right-click on a link, and select Open link in New Window, then a New Private Window is created with the link automatically entered in the URL field . . . and then, sometimes, the “site can’t be reached” or access fails or some message like those.

But, if I right-click on a link and COPY the link, and paste that link into the URL field of a New Private Window, usually the problem is overcome.

Or, sometimes, a few Reloads will “fix?” the problem per web page (but not FIX the problem).

Hi.

I tried that but it’s just the same for me whether I select ‘open in a new tab’ or just copy and paste the link. I still get the error message.

It’s not a big problem because the page opens after a couple of seconds, but it’s a bit irritating, that’s all, and I wish it didn’t do it. It’s clearly a Brave issue because it doesn’t do it with Chrome or MS Edge.