Unable to log on to bank website

Error message: Access Denied

You don’t have permission to access “http://onlinebanking.pioneerbanking.com/” on this server.

Reference #18.1719df17.1647274037.25ee208a

URL is in the error message.
The bank claims this problem, and this message, comes from Brave, not them.
Behavior is unchanged with or without shields.
Never use Chrome, but works on Firefox.
Brave 1.35.103

I see similar complaints, but no replies. ?

my brave can open this link effortlessly. check if you have any adblocker…dns or anything else that protect and scans network.

@Glencul ,

Settings Management Help ref.:

With Brave Browser running, in a New Window, go to brave://settings/clearBrowserData

Examine all the settings for all three tabs: Basic / Advanced / On exit

Be certain that those settings are what they should be, for your usage. In time, you will have tested those arrangments, and figured out what you need, there.

IMPORTANT: The cleaning / clearing away of cookies, thru that process, WILL NOT REMOVE ALL of them! If you are intent on removing all cookies, then you must also, in a New Window, be sure to go to: brave://settings/siteData and manually remove sources for cookies, there.

Quit Brave Browser. Wait a moment. Start Brave Browser.

In a New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter www.pioneerny.com as the site . . . but do not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for:


Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter www.pioneerny.com as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Repeat those steps for:


In order to learn, what website sources (of cookies and scripts) may be involved, learn to use the Developer Tools > Network tool for monitoring items, and use the Developer Tools > Application for learning sources of, and examining, Cookies.

How to use Developer Tools




Developer Tools > Network tool is where you search for sources of scripts and other items that will qualify despite their not being obvious scripts.


Developer Tools > Application tool is where you will find the sources of cookies.

PS The correct links (both use https, not http):

https://www.pioneerny.com (and click on the Login button)

I don’t have a login to test, page opened fine. Does it work in private window mode ? @Glencul (or possibly try a new Brave profile)

Okay, Brave just recently started giving this error “access denied” to all bank type websites… I was able to logon and access statements until just recently. I’m not apt to go through all of the technical steps above to access my accounts. Does anyone know if there will be fix for this bug? Since I am using this for work purposes it it a big deal to not have access.

I switched to Firefox to simplify the environment.
On two otherwise identical android tablets, l have different versions of Firefox. On the latest Firefox release, l get the same resulting permission error message l get on Brave. The earlier version works just fine.
I tried to implement the exhausting technical steps suggested, but without much clarity on what exactly to set or specify, l’ve no good reason think l did everything correctly. Bottom line is after spending hours on this, nothing l did made any difference.
My current working assumption is that something in the recent releases of Firefox (and thus in Brave built on top of Firefox?) broke the bank’s process.
Although l still don’t know if the error message eminates from the bank or the browsers.

@Glencul , @Nevada ,

Using Brave Browser, given the suggested cookies and javascript adjustments mentioned (and updated, today, Apr. 5, 2022) in my reply 3 . . . Go to www.pioneerbanking.com:


Their web server promptly affects a redirect to www.pioneerny.com:


where you may click on the PioneerNY.LoginButton button, and get a LOGIN prompt:

For User ID, I entered “tempID” and clicked on the LOGIN button; and the result is a window served by onlinebanking.pioneerbanking.com:

Now suppose, using Brave Browser, given the suggested cookies and javascript adjustments mentioned in my reply 3 . . . you go directly to onlinebanking.pioneerbanking.com and hover the mouse arrow tip very near the PADLOCK icon at the left end of the URL address field:

You should get a small “View site information” piece, that indicates, if you right-click on the PADLOCK, you may view site information; and, DOING THAT, you may select (click on) “Cookies” and see cookies that are established:

One selection down from “Cookies” in the “View Site Settings” pop-down window that resulted from your right-click on the PADLOCK, is selection, “Site Settings” - choose that; resulting in a trip, in a Brave Browser New Window, to:


where you may view nearly every Brave Browser setting for the website, onlinebanking.pioneerbanking.com . . . save specific Cookies settings:


and, the Shields settings:


such as:

Upgrade connections to HTTPS: ENABLED
Trackers & ads blocking: STANDARD
Fingerprinting blocking: STRICT

I do not have an account at Pioneer Bank, but Brave Browser otherwise navigated the various windows without restriction.


Its the VPN causing issues, I got the same error;

Access Denied

You don't have permission to access "http://onlinebanking.pioneerbanking.com/" on this server.

Reference #18.59b11702.1649233847.5473e0d

Disable the VPN for the banking site (and/or secureDNS)

1 Like

Confirmed. Toggling vpn connected/disconnected toggles acess denied/allowed.
Thank you!

Don’t understand how this interacts with browser version (for Firefox anyway–older version has no problem), or if there is some setting somewhere that will enable the vpn protection (for banking, no less!) but this is a workaround l can live with.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.