Online bank refuses Brave connection!?

Description of the issue:
My bank has suddenly decided to refuse the Brave browser to connect to its online service.
I’ve been happily using Brave for years to do this, but it appears the bank has suddenly decided to ‘block’ Brave.
I contacted them to ask why this was done but have received duplicate replies along the lines of “the Brave browser is a small and ‘anonymous’ browser”.
Of course, this isn’t any answer to my question as to WHY the bank has suddenly decided this.
Before, I take this further with them, I’d love to hear from anyone with advice on why the bank would do such a thing? Have other banks/companies/institutions done this before?

Exact URL of the website in question:
https://www.caterallenonline.co.uk/?ei=1&m=1
The resultant page gives a " Online Banking Unavailable" message. Which is misleading as you can access via Chrome.

Did the issue present with default Shields settings? (yes/no)
Yes, I tried with all shields down! same result.

Does the site function as expected when Shields are turned off?
No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No
Does the site work as expected when using Chrome?
Yes.
Brave version (check About Brave):

Version 1.19.92 Chromium: 88.0.4324.152 (Official Build) (64-bit)

Thank you!

Try lowering brave shields for ur your bank s site

certain sites don’t want to deal with “unknown” browsers whether or not they actually work…they don’t want to deal with any possible problems for users of a browser when that browser makes up a small % of their audience… and sometimes they sniff your user agent or something to make sure your browser follows their requirements… I always keep a couple of different browsers just for such occasions…

Already tried this but got the same result.

Thanks for your reply.
So Brave, which I thought used the same underlying code as Chrome, still has enough differences to the major browsers that would interpret websites differently? Therefore companies would still need to develop for it too?
Is that right?

At what point does it fail? When I try that link it forwards to another page ( https://www.caterallenonline.co.uk/WebAccess.dll ) but there is no error message (yet?).

If you send me your login details I’ll try if I can log in here. Oh, but for security I will need you PIN and your mother’s maiden name as well. :wink:

Joking aside, you say you have tried lowering shields for that site. Have you tried setting up a new profile and logging in from there?

1 Like

Page loaded fine here (Have no login to test auth), are you using Trusteer app + extension? @CrystalSurfer

1 Like

Thanks for your input folks. Looks like you solved it.
I’d forgotten about Trusteer, so have installed it and then I tried logging in as a fresh user - it works!
Thank you for your help!

2 Likes