Unable to install any extension

Description of the issue:
Can’t install any extension from chrome webstore.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go to webstore, select any extension, add to brave, says checking, after15-20 seconds it says an error has occurred, download interrupted, download page says failed network error.

Actual Result (gifs and screenshots are welcome!):

Expected result:
Extention added

Reproduces how often:

Every time.

Operating System and Brave Version(See the About Brave page in the main menu):

1.46.140 Chromium: 108.0.5359.99 (Official Build) (64-bit)

Additional Information:

I’ve read many posts on this. I’ve uninstalled and reinstalled Brave, I’ve disable all extensions, turned off shields, no vpn, no firewall beyond win11 security, disabled win security, still not able to install any extensions.

Installing extensions in Firefox happens instantly.

This may or may not be related. I haven’t tried downloading any new extensions for a while so it may be merely coincidence. A few days ago I installed a new windows update which caused all the pinned apps in my taskbar to disappear. I rolled back the update, still no taskbar apps. Finally, I found a utility to diagnose and restore the taskbar.

Any help?

Hi @Terryba welcome to Community :wave:

Is this is an issue on Chrome as well?

Hmm, don’t know. I don’t have chrome installed on this pc. I’ll check that out and report back.

I just installed Chrome, add an extension successfully.

Thanks @Terryba for the update.

Just so that we can isolate if this is an issue specific on 1.46.140, can you test out if this issue persists on Brave Nightly?

Sure. Where do I get the nightly?

You can download Nightly here - https://brave.com/download-nightly/

I installed the nightly, attempted to add a couple of extensions. No go.

The time the error message came up instantly. It didn’t say “checking”

Thanks for trying @Terryba

We’ve brought this to the attention of our team.
Once I know more I will reach out.

It occurs to me that I should mention that when I uninstalled my version of Brave, I did so without deleting the app info so all my extensions, bookmarks, etc. were restored with the new install.

Hi @Terryba
Unfortunately, we’re unable to reproduce this issue on our end. I had no issues installing extensions on both macOS and Win11.

I’m curious if you go to brave://settings/privacy > security and temporarily toggle No Protection if this would allow you to download that extension?

Hmm. When I try that url, I get “this site can’t be reached”.

I’ve made an edit, you can always find this by going to your browser settings brave://settings and on the left side you will find Privacy and Security

OK, I turned off protection in Brave. Still not able to add extensions.

I also just tried this on my laptop and found I was unable to add any extensions to that installation of Brave. So I have two separate installations of brave to two machines, neither can add extensions. What are the odds, given you can’t recreate it there.

So I though perhaps its a network thing. So I fired up a hot spot on my phone and connected my laptop to it and was able to install an extension.

So back to my desktop, I again turned off windows real-time virus protection, firewall protection, for domain, private and public networks, still unable to install any extensions.

So this does seem like it may not be a Brave issue, except that I can install extensions on my other browsers including chrome.

So this may be beyond the scope of your role in this, but I don’t know how to resolve this.

I decided to try a complete reinstall of Brave and deleting all the app data. (I save a copy).

When the install was complete I noticed an error message in the menu button.


When I click on this it says New extension added.

And in the extentions tab there it is.

Is that normal? I wouldn’t expect Brave to come with any extensions already installed.

In any event, I tried to add a new extension and it failed. This suggest to me that my extensions, bookmarks, user data are not a factor in this.

Thanks for sharing everything above.

It is strange that Adobe extension was installed, you didn’t have this installed in the past by chance?

If this worked, then it could quite possibly be a network issue. However, other browsers are still unaffected.
Tagging @Mattches if he might have any ideas.

Can you confirm that after the complete reinstall that no extensions download/install properly?


I did have that extension installed previously, but when I uninstalled I check the box to not save any user data. So I would not expect that to carry over to the new install.

Also the error in the menu button is odd.


I can confirm, I’m unable to install extensions after the complete reinstall.

I had the same issue. Turning of “NordVPN Threat Protection” fixed it for me.

Kieran Thanks.

Glad that worked for you but I’m not running any vpn. Dang. . .