Can't download chrome extensions

windows
#1

I can’t download extensions from chrome web store
when I try to download from Chome it works fine but when I try to download from Brave it keeps “checking” for a few seconds and then says was a network error.

I turned off my antivirus, booted in safe mode but nothing worked.
I’m not using any wpn software.

I’m using Brave 0.62.51 on Windows 10 Build 17763.

#2

@wesam,
Thanks for reaching out!
We released an update yesterday - and ahotfix today containing a chromium bump - that may be causing the issue (difference in chromium vers.). Can you update to the latest release and test again? Should be v0.62.51 at the time of writing this.

1 Like
#3

Thanks for replying so quickly!
I’ve just updated Brave to 0.62.51 an hour ago but the problem still persists

1 Like
#4

@wesam,
Good – just wanted to make sure we were working with the same set of tools. Can you tell me if you have any other extensions installed currently? If so, are they functioning properly?

#5

I haven’t been able to install any extension yet. I just download Brave yesterday and everything works fine except for extensions.

#6

That’s very strange. I’m testing on my end right now – in the meantime, can you try clearing your browsing data (Menu --> History --> Clear Browsing Data) in case there’s a caching issue at play? Make sure you restart the browser after data is cleared.
Let me know what you find out.

#7

I cleared all data, uninstalled and reinstalled Brave but I still can’t download extensions.
maybe it has something to do with having both Brave and Chrome at the same time?
I don’t know it just feels weird.

#8

Yeah that is very weird. Give me some time to reach out to the team and perform a few tests on my end – appreciate your patience. I’ll return with what I find out.

1 Like
#9

Also, do you have any browsing data in Brave that you want to avoid erasing? Passwords, bookmarks, history, etc? I know you said you only downloaded yesterday but I just want to make sure before I suggest something that might do that.

#10

No problem, actually I already did that

#11

Clearing browsing data doesn’t remove clear bookmarks but good to know. In that case, when you went to uninstall Brave, you should have seen a prompt to delete/remove associated browsing data as well – did you do so?

#12

I have the same issue. can’t download any extensions… also dragging the chrome IDM integration extension to brave fails to install and gives an invalid header error…
Also downloading the same extensions from another online store gives the same network error…

I’m using the latest DEV version of brave… now downloading the new stable mentioned above, and will report if the issue is fixed

#13

@Mattches
No, it didn’t even show me the uninstall window, it just did it straight away.
then I deleted all the files in Program Files and AppData to make sure everything is brand new when I reinstall.

1 Like
#14

Alright installed the latest stable after a complete uninstall and cleanup… still have the same problem

#15

:point_up: This is what I was checking – wanted to make sure profile data was removed completely. To be clear (for anyone just tuning in or doesn’t know), to fully delete and start with a fresh profile on Windows OS:

  • Uninstall Brave using system Add/Remove programs
  • Locate locally stored files in ~\Users\[your user name]\AppData\Local\BraveSoftware

I’ve reached out to some team members for additional input, appreciate your patience.

1 Like
#16

I have the same issue. i tried reinstall brave, clearing all data and creating new profile on brave and all tries failed and i still can’t install any extension.
I have brave Version 0.62.51 on Linux.

#17

@Mattches
UPDATE!
I was watching a stream and suddenly Brave notified me that Avira Browser Safety extension has been added via a third party.
It seems that Brave is ok with having extensions, he just can’t download them from the web store.

1 Like
#18

@Mattches
An easy (and temporary) solution would be to enable the user to manually add extension by dropping .crx files.
Is there a way to do that? (and the user will take full responsibility if Brave was damaged by an extension he/she added)

#19

Sorry for the late response everyone. We’re still looking into this – exact cause is unclear. @wesam, I tried manually adding a .crx file but this also threw an error so I suspect they’re some background shenanigans taking place.

Will return when I have more info.

#20

So I haven’t used Brave for some days now still waiting for a solution.
but today I had a thought that I could use a VPN so I installed Avira Phantom VPN.
and for some reason Brave was able to download extension while using VPN.
it’s a bit slower than my usual download speed, but nevertheless it is working!