Unable to connect uphold wallet in android brave browser

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

How can this issue be reproduced?

  1. Verify wallet , after uphold MFA entry redirects to verify wallet once again

Expected result: connect to wallet or wallet connected

Brave Version( check About Brave): 1.30.87

Mobile Device details LG thinq

Additional Information:

5 Likes

On uphold’s site, try adjusting shield settings for the site. I have uphold allowing all cookies on mine. Also, log into uphold and keep the tab open. Then after, try to verify wallet.

I do that, but doesn’t help. Device limit is the problem. I checked the logs and have it confirmed

same issue here also and it is showing “Sorry there was a problem processing your request, please try again.”

Wait until brave solves it

I am also having same problem.

I use brave browser which is connected to uphold wallet. My uphold account is loggedin via globalid.

So when i connect brave rewards it gives an option to connect with globalid to uphold account. But its not able to login. If I use the uhold wallet app and connect using globalid, I am able to proceed in the wallet app, but the brave browser is not able to connect.

I have the same issue. I finally have enough BAT to verify my wallet but when I login to Uphold and click the verify wallet button it never verifies.

1 Like

I have been unable to verify my wallet for android for almost a year now on 2 separate phones. This is so f*ing frustrating. I don’t want to be told my BAT is safe. I don’t want to be told to wait anymore,

I have same issues aswell

Same issue. It looks like everything worked but the “Verify wallet” button does not update to “Verified”, and on the uphold account it says that it is linked to Brave

Well Brave support W T F are you doing to fix this issue!

same here, never get an error just cycles back after logging into uphold

Having the same problem. Hope to see a reply here soon from the dev team for a fix.

They are busy trying to repair their reputation.

I figured out the issue, for some of you this will work. It Did for me. Others may be facing a different problem.

  1. Open your Uphold wallet
  2. Click the more tab on the bottom right
  3. Click Settings
  4. Click the profile section
  5. Click the giant verify wallet banner

I had to submit my drivers license and a photo (Canadian regulations I believe). Then it said I was verified.

I then went to the brave mobile browser again, clicked the triangle and tried the verify wallet thing again. This time, it said ‘wallet verified’ and gave me 9 notifications of BATs being added to my uphold wallet.

I think this particular issue could be resolved by brave by informing people to open the uphold app and verify the wallet there, since that’s what they mean.

1 Like

Seems like we are conflating a lot of issues here.

If you are seeing the “device limit reached” message
This means you have linked the maximum number of devices to your Uphold/Gemini account that we allow at this time. Please see the following post for information on how to submit a wallet unlinking request:

If you are stuck in a wallet verification loop
If you go to Verify wallet and run through the Rewards verification process, complete it, and receive no errors/error messages, but your Rewards page/panel still shows Verify wallet, you’re likely stuck in a verification loop. This can happen when Uphold can’t communicate with the browser due to blocked cookies. For this, try logging into Uphold.com, opening your Shields panel and changing the cookie control setting to Allow all cookies, then try the verification process again.

If you are seeing a wallet verification error
I believe this could be due to a couple things:

  1. Your wallet is in a corrupted state, in which case you will likely need to reset your wallet. You can tell if your wallet is corrupted by going to brave://rewards-internals and checking to see if there is a Wallet payment ID on the General info tab. If there is not, your wallet is likely corrupted.
  2. You have not completed Uphold’s KYC requirements.
  3. Your wallet has been flagged.

If you believe you fall under case 1 or 2 above, please send me a DM and I will do my best to assist you. For #2 above, simply complete the KYC requirements in your Uphold account and you should be good to go.

3 Likes

Thanks for all the answers. However, here is my problem

My wallet is created on 25 April 2021

I tried connecting to uphold , it gave me drive limit reached. I tried connecting to another uphold wallet , it said uphold wallet mismatched.

How can I fix it?

I raised ticket to remove two of my wallet ids which I don’t recognise , waiting for it to be removed

I have only one Brave nightly verified wallet on my PC , , I have on phone brave and Brave beta, and after update software I loose linked wallet.
when I go to brave://rewards-internals general info, I have there more than one browser werified, how to unlkin them . what to do?

Thank you Mattches, for the info. I submitted the request for the account removals. Im wondering typically how long those requests go? After having dealt with it for months and not checking the forums (my fault) I’m now excited to finally get it fixed. Thanks!

This has been more than 2 months since this issue appeared after Android 12 update.
On Android 12 mobile app of Brave, I just can’t connect/verify the wallet using Uphold login! It just doesn’t connect at all. Totally frustrating!!
When is Brave gonna solve this problem?