Can’t Connect Uphold Account to Rewards

I can’t connect my uphold account in the mobile browser, I have tried several times without success, it started after updating the app, can you help me?

9 Likes

Same problem here. “Something went wrong” while trying to log into Uphold via brave. @steeven

10 Likes

Same problem here. I have had this problem for three months now and only with brave android. I got a lot of BAT locked in on my browser since then

7 Likes

I’ve had the same issue here, and Uphold seems to think it’s a Brave issue. From what I’ve gathered, for some people it might be an issue with too many linked accounts, but I don’t think I’ve passed that limit. My original support ticket to Uphold is below.

Hello! I’m having an interesting issue with verifying my Brave Rewards through Uphold. Every time I’ve tried to integrate them, (using the Verify Wallet link within the Brave Browser on Android), it opens the app, shows me the expected screen, and I tap the Authorize button.

At that point, I get an error that simply says “Something went wrong. Please try again.” There’s no indication within Uphold or the Brave Rewards page that the pairing was successful, but for some reason the Brave Browser still shows up on Uphold with a little green Connected button next to it. Tapping on it shows me all the info I’d expect to see about which permissions I’ve allowed etc, but the Site URI link gives the same error message and my funds are nowhere to be found in the app.

For what it’s worth, the uninstall icon in the corner works just fine, successfully removing the pairing (if it was ever even there in the first place) with no complaints. Repeating the process on different days with different WiFi networks yields the same results. Any ideas on what’s going on and how I can fix it? Thank you so much!

4 Likes

All of these issues I’m having too. Still no remedy after searching the community for 3 months +

5 Likes

Currently having this problem.

3 Likes

yeap same situation here on my android device. it says oops something went wrong.

2 Likes

This is also me… i thought it was about me having linked up too many accounts… So i already asked to unlink an account, but i think theres a huge backlog requesting issues to be resolved.
The annoying thing is, that my most used browser has this some error… oops something went wrong…

At Uphold side, they say everything from their end seems fine… Its from Brave’s side…
so please help

2 Likes

@Adrioz90 ,

5 Likes

Same problem here, and better tell us if there is no solution I’ll stop using this browser on my phone

2 Likes

Yep, to all the previous comments.

1 Like

I also have this issue now. I have never had this issue before. I only have 3 linked accounts not 4. When I go to verify and then authorize it says something went wrong please try again. I don’t have 4 accounts only 3. Never had a problem until two days ago. Still can’t verify and authorize. Really would like to have my account verified again considering it’s been verified for the last 10 months!

Yeah, it’s definitely a Brave problem. I completely closed my Uphold account, and made a new one entirely (Since having more than one account at a time will screw you over). Once I got everything setup, I attempted to verify the new account through Brave Rewards, and got the same exact “An Error Occurred. Please Try Again” message as I would with my old Uphold Account.

Since there’s really no chance of them ever fixing this; might just have to take the loss by resetting the wallet and starting over. Knowing our luck, even with that done, we would probably still get the same bulls*** error.

2 Likes

Some community members have had success following the below instructions. This will not work if you have reached the device limit but you may get a new message.

Same instruction but more step-by-step:

3 Likes

I did this exact procedure and got an error saying, “Device Limit Reached”. I put in a request to remove all devices except my desktop wallet, which works, and after about 10 days I got a response saying that it had been processed. However it didn’t help. I put in a second request but never got a reply, it’s been about a month since then.

They did mention that these limits will be removed sometime in March, so​:crossed_fingers:t4:. Hopefully that will fix this extreme inconvenience, and everyone will get 100 BAT for their troubles. :rofl::joy::rofl::joy::rofl:

1 Like

You can only remove one device currently. So if a device is removed, a user cannot file another request to remove one of the other device.

I read that it will take some more time for the new feature. It might become available in May.

I have same problem… Uphold not getting connected with brave rewards

This whole Brave saga is starting to seem more and more fishy every day. Problems linking to wallets, BAT disappearing and various other issues. It’s not a lot of money in most cases (I’ve got about $100 worth of BAT spread over 3 browsers) but multiply that by x thousands of users and someone’s making a pretty penny somewhere.
And never a peep out of the ‘owners’ to the multitude of threads about these issues, other than the occasional ‘we’re working on it’. (Working on what? Their tans?)
As I said…fishy!

3 Likes

I have a work around for this but the thing is I’m not sure if you’ll get flagged. My account was already verified and received brave rewards on Uphold a few times. I just happen to notice my Brave on Android was disconnected so I tried reconnecting but it always fail. Not sure if this was the reason why my account was flagged but If you still want to try it, then here’s what I did:

On Android Apps settings, Disable/Change Open Supported Links on Uphold App and change it to ‘Ask Every Time’. Try to reconnect your account again and instead of using the Uphold App use the Brave Browser.

But I still, I warn you, I got flagged and I’m not sure if this was the case.

Delete the Uphold app. You can reinstall it later. Just uninstall the app and then open the Brave Browser, tap Rewards and Verify. Instead of launching the Uphold app (preventing you from accessing the correct link) it asks you to log-in via the Browser and instantly allows you to verify your wallet.
Afterwards, for managing your BAT, you can reinstall the Uphold app and all is fixed! It’s TOO BAD I couldn’t get this answer MONTHS ago… SMH.

2 Likes