Unable to verify brave wallet with uphold (Android)

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:
Not able to verify my mobile brave wallet with uphold. When I try to verify, it simply redirects me back to home tab after successful login to uphold account and there is still that ‘Verify wallet’ button over there on wallet.
How can this issue be reproduced?

  1. open brave rewards
  2. Click verify wallet button
  3. login to existing uphold account

Expected result:
Brave wallet should get verified after login and successful auth to uphold
Brave Version( check About Brave):
Mobile Device details
realme 7i (RMX2103) (android 11)
Additional Information:
The uphold account is already connected with my brave on PC.

login with Uphold.com by typing into the address bar of the browser. Then login with wallet. Hopefully the problem will be solved

I tried this method. Still same thing happened. I authorized the wallet with uphold and it simply showed me ‘verify wallet’ button again in rewards section. Then I again tapped on verify button, after which brave closed automatically.

1 Like

I’ve been having the exact same issue ever since I had to reinstall Brave on my phone. Before the reinstall I had my Uphold wallet connected and there were no issues. It’s been going on for several months, and I have attempted to connect to my Uphold wallet dozens of times. VERY frustrating!

1 Like

The thing is Brave automatically open the app instead of the browser. I mean it tries to verify the account through the app and not through the browser. I solved it by uninstalling the app, then verifing my uphold account through the brave browser and once verified, I installed the app again. Could be nice if this issue is fixed in the future.

1 Like

Thank you a lot!!!
This is a ridicoulus bug… i have had the same problem, i’ve open topic on the community without to receive any answer… than i found this topic almost hide…

Thank you again, but orrible bug!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.