Unable to connect Uphold account with Brave Rewards

Yeah, we won’t, right?

@ivancastrothefool and @gna big thing to double check is if Limited Uphold account functionality may also be part. It’s occasionally been an issue and is part of their KYC/AML process, but not made easily to find and do.

I’m only mentioning this part because of what was said by Evan123 earlier. At least having you attempt the steps and see if it comes up and lets you connect afterward will confirm if it’s an issue.

Attempt what steps? There is no more verification required on my part, otherwise I would not be able to successfully attach my Brave Browser to their interface as previously stated.
image
image

I have confirmed from their support chat that my account is fully verified with no further required action and they are unable to provide me with further support on this issue.

It seems the issue must then inherently lie with Brave Rewards

That’s also my case.
brave_teXPFMQjPA

having the same problem
I tried to find solutions in the post by [Saoiray] in the following link

so i got the App. but to initiate a withdraw you need to make a deposit first.
did some people try and succeeded?

So essentially, what you’re claiming is this issue is stems from Upholds verification process, even though the entire process needs to be initiated from the Brave Browser in order for users to even realize they NEED to be verified before attempting to connect?

Sounds like an extremely poorly ran process that traps the majority of Brave vBAT users into eventually giving up on attempting to retrieve their rightful balance owed.

I have to hand it to Brave, a very well thought out strategy on how to scam as much money as possible.

1 Like

The steps provided in the link I shared.

Did they change it? Shouldn’t need to make a deposit.

Yes this information would be useful if it weren’t for the fact I have already completed these steps before you linking it.

i didnt find how to withdraw
but I just got my uphold account verified like 1 hour ago, i may need to wait until tomorrow to get the account active or somethin

Correct, there is no option to withdraw from a fully Verified Uphold account.

Again proving that these Brave workarounds are an inherent issue caused by a bugged internal process on their end.

It is an Uphold thing, not Brave. Hence why I even had a screenshot of email reply from Uphold giving the instructions of what to do in that link I shared.

You’re speaking more of anger and hostility, perhaps even mixed with a bit of ignorance naivety (Not sure proper word here, but lack of understanding but speak as if you understand. It’s due to going off of assumptions). It’s okay to show frustration and all, but try to be accurate in what you’re saying.

do you have a feedback from a brave user that actually managed to get his BAT with uphold after using that method you shared ?

Hi all,

I have the same problem,
My Uphold account is verified and I succeded to connect it on two laptops I am using occasionaly yesterday.
Today I tried to do excatly the same on my desktop computer but I have this error: “Your request is still being processed, please wait. Sorry there was a problem processing your request, please try again.”

With the following error in the logs:
[Oct 29, 2023, 6:57:07.3 PM:ERROR:post_connect.cc(77)] Unknown message!
[Oct 29, 2023, 6:57:07.3 PM:ERROR:connect_external_wallet.cc(186)] Failed to connect uphold wallet!

Why my uphold account can be linked on my laptop and not on my desktop computer?
Can you please help me besause I have much more vBAT on this desktop than on my laptop that I don’t want to lose.
Thanks

do you have heard from a brave user doing the method you shared, and succeeding in getting his BAT back with uphold?

Oh, the party is in this thread? I’ll start watching. Having the same issue as the others, but on W10. Account is fully verified with Uphold, but getting the “Request is still being processed” error.

Yeah, there’s plenty.

Again though, that’s just for people having that issue. So looking to see if people are having the notice as mentioned by Evan123 earlier:

They had identified some were having this issue. It just wasn’t giving the Limited Uphold Functionality message like normal. But it doesn’t mean everyone experiencing the problem of it not connecting is having this. It’s just one step for people to try and it should resolve for some.

Yes it does show KYC_required but I have completed all the verification process with Uphold and there’s nothing else to verify.

@CeruleanStar did you try to withdraw and do the steps as mentioned in the links just above? The Limited Uphold account functionality steps?

Keep in mind that some are quick to argue. Unfortunately there are some differences between what people think and what gets communicated. Like for Uphold, they’ll advise that all of your KYC/AML is done because they see your documents and Uphold overall is kind of content. What they don’t look at is how their API will report to others, including Brave, that you’re not fully verified because of the minor step like the Liveness check.

Over the years, I’ve had people argue and insist everything was done. But then they finally took the step suggested and they saw that Uphold did indeed have the one extra step required. Their support agents just were dumb and didn’t advise. And they don’t make it easy to recognize it needs done, with no notice even being given in your account until you actually go to do the withdrawal.

And just to repeat what I said earlier, I’m not insisting this is the issue for everyone who is having this issue right now. We can only take some of the clues being shared and take a step at a time. If you go to brave://rewards-internals and it says KYC_required then we know there’s something in the API. This means either passport, bank information, email confirmation, or liveness check.