Unable to connect Uphold account with Brave Rewards

Briefly describe your issue: I am getting the " Sorry there was a problem processing your request, please try again." error when attempting to connect my Brave Rewards wallet to my Uphold wallet. When I go to rewards internals, I see these 2 messages that relate to the issue:

[Oct 28, 2023, 7:20:15.0 PM:ERROR:post_connect.cc(77)] Unknown message!
[Oct 28, 2023, 7:20:15.0 PM:ERROR:connect_external_wallet.cc(186)] Failed to connect uphold wallet!

What Operating System and Brave version are you using? Windows 10; Brave Version 1.59.124

Who is your verified custodian? Attempting to connect to Uphold

Are you in a supported region? Yes.

1 Like

I"m having this same issue on my PC and Phone with Uphold
I get the error message

[Oct 28, 2023, 8:15:51.3 PM:ERROR:post_connect.cc(77)] Unknown message!
[Oct 28, 2023, 8:15:51.3 PM:ERROR:connect_external_wallet.cc(186)] Failed to connect uphold wallet!

Im using Windows 11, Brave 1.59.124 on my PC and Android 14, Brave 1.59.124 on my phone

How do you find the internal error message? I am running into a very similar issue after verifying my account, I have Windows 10, Brave Version 1.58.137.

I have the same message error “sorry…”.

I have same issue is with Brave Beta on linux.

1 Like

I can confirm this behavior also on my Linux box.

Brave Version:

Version 1.59.124 Chromium: 118.0.5993.117 (Official Build) (64-bit)

Linux:

Fedora Linux 38 (Workstation Edition)
64-bit
GNOME 44.5
Wayland
Kernel Linux 6.5.8-200.fc38.x86_64

Same issue on MacOS

Version 1.59.124 Chromium: 118.0.5993.117 (Official Build) (x86_64)

Same issue on a Mac. I’m going to lose all my BATS and cannot reach anybody on Uphold chat. Not cool.

[29 Oct 2023, 1:36:25.6 pm:ERROR:post_connect.cc(77)] Unknown message!
[29 Oct 2023, 1:36:25.6 pm:ERROR:connect_external_wallet.cc(140)] Failed to connect uphold wallet!

I am having a similar issue on MAC, brave version: 159.124

Same issues, funny how it only happens in countries where Uphold is accepted :slight_smile:

Also funny, how it’s literally the anniversary of me having to come here to complain about the same issue, and it not being fixed or even addressed. Now we all lose all of our vBAT just like they intended :slight_smile:

1 Like

@gna @rockgod13 @CeruleanStar and others. Can you check at brave://rewards-internals and look at your Event Logs. Do you happen to see KYC_required listed?

Yes. But, in my case, it has yesterday’s date, when hadn’t confirmed my identity yet.

10/29/2023, 01:03:28 AM | kyc_required | uphold |

This is with having a verified Uphold account, confirmed by their support and with the Brave Browser integration active on their interface, with multiple attempts to disconnect/reconnect it to no avail.

Surely we all won’t lose our vBAT because of an internal issue.

Yeah, we won’t, right?

@ivancastrothefool and @gna big thing to double check is if Limited Uphold account functionality may also be part. It’s occasionally been an issue and is part of their KYC/AML process, but not made easily to find and do.

I’m only mentioning this part because of what was said by Evan123 earlier. At least having you attempt the steps and see if it comes up and lets you connect afterward will confirm if it’s an issue.

Attempt what steps? There is no more verification required on my part, otherwise I would not be able to successfully attach my Brave Browser to their interface as previously stated.
image
image

I have confirmed from their support chat that my account is fully verified with no further required action and they are unable to provide me with further support on this issue.

It seems the issue must then inherently lie with Brave Rewards

That’s also my case.
brave_teXPFMQjPA

having the same problem
I tried to find solutions in the post by [Saoiray] in the following link

so i got the App. but to initiate a withdraw you need to make a deposit first.
did some people try and succeeded?