Aggregate Topic: Unable to connect to Uphold

I keep seeing a lot of new topics being created, so I’m merging over into one to make it easier to respond to everyone.


It is a known issue for the past week or two that many people can’t connect to Uphold. Users are receiving a notice saying there was an error processing the request, such as below:


Support and many from Brave were on vacation due to Christmas, New Years, and other end of the year holidays. I had made @steeven, @Mattches, and @Evan123 aware. The teams will be looking into this and it just is going to take a bit of patience from everyone.


I have other devices connected to Uphold wallet but I can not connect my PC. I opened a ticket in Uphold support but I couldn’t recieve a answer yet. This is the report that sent:

I couldn’t connect my Uphold wallet with Brave Rewards (only on my PC, in my mobil device is connected) When I try to connect send me an email asking me if “it’s me” or “No….” I pick “it’s” me and I can log in on my account but when the tab of Brave Rewards can’t connect and show me a pop up

“Your request is still being processed. Save a moment.
We’re sorry, but there was a problem processing your request.”
and a button “Retry”

but clicking again and again I can not connect
Do I have this issue because a problem in Uphold wallet or a System of Brave Rewards ?


do you know about this issue?


Im having this issue too, can log in to uphold but it remains logged out in brave and says the same message as above

My phone browser has now changed to showing its earnings now how odd


Im having this same issue aswell.

When trying to login to Uphold wallet, after a successfull login on uphold login process i get redirected to rewards page with the above message.

Hi all,
same problem here, I’m trying to connect Brave to my verified Uphold account but it’s giving me same error.
I’m trying on PC browser and on Android browser, same problem.
So I entered on brave://rewards-internals (logs section) and I noticed this

[28 dic 2023, 9:28:10,2] Unexpected HTTP status: 426
[28 dic 2023, 9:28:11,0] Unknown message!
[28 dic 2023, 9:28:11,0] Failed to connect uphold wallet!

1 Like

Same issue here for connecting.

I had a Major issue with my C and had to wipe and reinstall thanks to windows 11 issues but moving on I redownload my preferred “Brave Nightly” and then begin the process to reconnect but just getting that Please try again.

I then waited a bit and checked my Uphold and such and which some weird reason it asked me to re-verify and so i then did and which then i tried connecting and which it did.

(Here is my F&$# up Though)

I had this weird Issue reappear again on my C to which my amazement was somehow it had 3 separate recovery partitions (not From my Fresh Install) made so i then had to do all that again and this time i full wiped C and started over but now this time when i tried to connect brave It instantly jumped to the “Please Try Again later” as to which I then checked my Mobile (android) and now my phone was disconnected from Brave. N.

Moving now to day 3, I have verified my Uphold now to the point the A.I./Person is most likely sick of my picture and again my account gets verified like that so yea it most definitely has to do with Brave core services overall even with me on Nightly.

Almost seems like IMO there is a limited amount of Confirm request it will likely allow say per month or maybe per year even (which is dumb if per year) and so now I am just waiting for this to fix because i rather not have to deal with support especially if it is well Brave core service syncing issues which should be fixed but that’s me being hopeful atm.

same issue here.
no solution from devs?

I have the same issue, have been using Brave browser with my verified Uphold account for more than a year, yesterday I used a VPN so got disconnected from my Uphold account (it’s happened before and I’ve always just re-connected to Uphold without issues), but this time when trying to re-connect to Uphold, Brave shows the “Your request is still being processed, please wait” error as the screenshots posted by others. Not sure why having re-connect issues. I can log into my Uphold account separately and can see the Brave-Uphold integration there.

Have tried deleting the integration and re-connection, same error in Brave.

Same issue here. Rewards page has link to ‘connect account’ but when i try to connect to my verified Uphold account I get the ‘your request is still being processed…’ message.

If I login to Uphold it tells me my Brave Browser integration is connected.

Same problem here. The Rewards page has a link to “Connect Account”, but when I try to sign in to my verified Uphold account, I get the message “Your request is still being processed…”. If I log in to Uphold it tells me my Brave Browser integration is connected
Could the DEV have pushed too hard on the eggnog?

I have a similar problem, but on MacBook. Same thing, but in Swedish. :slight_smile:
Looking forward to getting some help, although I agree with @saoiray that the guys at Brave need their vacation :stuck_out_tongue: hope to hear from them in the coming week(s)

1 Like

Having the same problem here, on PC and Android

Same issue. I thought it was a regional issue, but I double checked and it should have been supported and only take 24 hours to approve. Just sitting and waiting for it to process now…

Same issue here, Windows 11, Brave browser, “Your request is still being processed, please wait.” multiple attempts, multiple diagnostic situations, at the point to reset profile, but I don’t think that will help either by the looks of it…

well great im mad impatient. I been having this bs since the 25th an nothin from support. im using mac os Monterey. it connects i can get into uphold but when i go to click the extention to connect to brave using uphold keeps doin same thing getting the error screen you guys been screenshooting in the thread. Like what can it be. I deleted reinstalled cleared cache everything is verified like shi* has to be on braves end

I has a same issue whole day, right before new year, really inconvenient situation …

Cómo se soluciona? no me deja vincular…

hey there. having the same issue since 10 days already.
tried to clean cache and switching off everything. tried for 10day in a row but always the same login error as reported above!

Please check look video explain no cant login:

Said translate:
Your request is still being processed, please wait
Sorry, there was a problem processing your request, please try again.

1 Like

I have a problème to connect brave and uphold

1 Like