Unable to connect metamask on Brave

I’m having issues connecting my metamask wallet to any site using the brave browser.

I have tried every metamask-supported website and it just doesn’t connect. What seems to be the problem?

The new update on Brave has been worse. I cannot access any of my metamask wallets on any website using brave.

I have tried switching from brave wallet (prefer extensions) to None and there’s no change.

It seems like Metamask doesn’t update automatically on Brave.

The new version of Metamask: 10.18.0, but on brave, the extension is still v. 10.17.0.

Is there a way to update metamask from brave directly? I don’t see the option on the manage extension tab as well.

Update: I uninstalled and installed the extension again to the latest version.

It still doesn’t work.

Try this:

ISSUE: Metamask Extension Issue (+ w/ Google Docs )
Workaround: Setting the default wallet to None on brave://settings/wallet

Sources:
Can not connect meshswap.fi - #6 by fanboynz
Google Docs not workling on Brave - #32 by fanboynz
Google Docs not workling on Brave - #25 by Dkpower

Brave GitHub Issue Report(s):
Error when entering site requiring Brave Wallet #24413
Remove window.ethereum.* (non function properties) protection #14483

It still doesn’t work

Well, I was hoping that workaround would work for you. I didn’t notice you had already tried this. Sorry I overlooked that information initially. Since the workaround didn’t work, you will need to provide additional details to help troubleshoot.

Please provide:

  1. Brave and OS version at brave://version
  2. Does it work in other chromium based browsers (examples: Firefox, Chrome)?
  3. Do you use a vpn or anitvirus software? Try turning them off if you do.
  4. Have you tried:
    • Clearing history/cache for all time, exiting browser, and reopening
    • Disabling shields?
    • Disabling any other extensions you may have?
    • Testing in Brave Beta and/or Nightly to see if the problem occurs in those versions?
  5. Just to confirm, you have been able to use Metamask in Brave before the recent update, correct?

Please provide an update.

@0xArhat New Brave version released today that may fix your issue. Please update to the latest version and provide an update. Thanks! :slightly_smiling_face:

Release Notes Brave version 1.42.88

  • Fixed webcompat issue on sites when default cryptocurrency wallet provider is set to “Brave Wallet (prefer extensions)”. (#24456 )

Do we have to download & install the browser again?

The browser automatically updates, as far as I know.

To check if you have the latest version:

  1. Go to your settings section
  2. Scroll to the bottom on the left
  3. Below reset settings, click on About Brave
  4. It should say 1.42.88 if you have the latest update

If you haven’t gotten the update already:

  1. You go here: and get the package and install that
  2. Restart the browser (maybe restart computer for good measure)
  3. Then you go here and clear caches since that might affect your extension

This is all I know to do personally, but I hope it helps!

1 Like

Did all of that. It still doesn’t work.

I had the latest version of Brave installed already.

But I uninstalled and installed it again. It didn’t work.

I reset all the settings and it finally worked.

1 Like

Woot! Glad the issue was resolved. I wonder which setting was causing the problem… would be nice to know even though no way to tell at this point. :laughing: I’m just glad you are back up and running as the saying goes. :slightly_smiling_face:

You should mark your post as the solution so that other community members and Brave support know your issue has been resolved (and how). It will also help other community members who are experiencing the same problem and searching for a solution.

Take care. :slightly_smiling_face:

1 Like