Cannot connect metamask to any website with new wallet upgrade

I’m having issues connecting metamask to any website with the recent wallet upgrade.

Plz help. Thank you

1 Like

@barrybrown5,
Can you go to Settings --> Wallet and ensure that you have the Brave Wallet (Prefer extensions) option enabled?

Yes, however, I am still having issues when clicking “connect wallet” on any website.

What exactly happens when you click Connect wallet?

Restarted my computer. Restarted the browser. Still Nothing. Can’t click on “connect wallet”. Can’t connect metamask to any web3 application.

Anyway, I can revert back to my old brave wallet?

@barrybrown5,
So you’re saying clicking Connect wallet does absolutely nothing? Can you share a screenshot of what it looks like when you attempt to do this?

Correct, I’ve tried on multiple web3 applications. Uniswap & Aave.

Here’s Uniswap for example, although you won’t be able to tell much since I can’t click “Connect Wallet”

Additionally, the brave wallet extension doesn’t connect properly even though from the settings page I’m connected correctly:
Screen Shot 2021-12-08 at 2.44.16 PM

This is what happens if I click “Not Connected” button:

@barrybrown5,
And you’ve given the site you’re trying to connect to the proper permissions to connect to any detected wallets?

Typically, in the past, a pop-up would show in the top right corner of my screen in order to approve the website for metamask. However, I don’t see that option when clicking “connect wallet”. Are there any alternatives to allow permissions?

@barrybrown5,
I think you can select this permission by clicking the “lock” icon in the address bar. Can you share a link to a site where you know you’re seeing this issue occur so I can test on my end?

I had to go to Manage Extensions and turn off Crypto Wallets and then I could connect MetaMask to Pancake Swap. But every time I open Brave I have to do that. It keeps turning itself on. What gives there??

@drummermike5150,
Do you have a native wallet set up at all or is this setting revering even without setting up a native wallet?

This worked! Ty @drummermike5150 @Mattches

Btw using Crypto Wallets (deprecated)

I don’t believe I ever set up a native wallet but when I got to Wallet under the hamburger menu it comes up with a blank screen so not sure.

I have my rewards setup with Gemini.

@drummermike5150,
Would you mind opening a separate thread here for your issue and include all the information requested in the editor so that we can better assist you?

Yes, I will do that…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.