Unable to block autoplay (setting don't work)

Hello! I am using Brave Version 0.64.77 on Windows 10 and even tried re-installing and also tried the Nightly version but still doesn’t resolve my issue.

For example on these sites:
https://www.twitch.tv/ and https://www.cnet.com/news/apple-wwdc-2019-keynote-start-time-how-to-watch-livestream-ios-13-more/

I set autoplay and autoplay sound to “Ask” or “Block” but still it autoplay video with the sound every time. I don’t get the ‘autoplay has been disabled for this page’ notification anymore.

1 Like

Thanks for reaching out.

Regarding twitch.tv. We have a whitelist of sites which autoplay will not be blocked (implemented in https://github.com/brave/brave-browser/issues/1089). There is an issue however that is immposible to actually block those sites (https://github.com/brave/brave-browser/issues/3138).

I added +1 from you.

Re cnet.com seems to be blocked for me.


You should check your autoplay settings in brave://settings/content/autoplay. It should be set to blocked.

When I change it to blocked it just switches back to “allow” Gif of the issue here:

And even if it says I have cnet on block the autoplay still happens.

1 Like

@btlechowski Where can I see and edit (destroy) that whitelist?

How did you get that drop down menus for autoplay?

For me on 0.64.77 Windows 10 it looks like this:


After clicking Autoplay, it shows:

The list is hardcoded and cannot be deleted.

image

1 Like

@btlechowski If you click the padlock next to a URL and go to Site Settings, it will take you to the drop down menus.

I have the same problem. Twitch autoplays every time no matter what I do and it’s driving me nuts

This topic was automatically closed after 30 days. New replies are no longer allowed.