How do I block video autoplay on tomshardware.com?

Media autoplay continues despite having BLOCK set in Brave’s for this specific site. Thankfully it plays with audio muted. Is there anyway I can get it to not play at all?

See for yourself at: https://www.tomshardware.com/news/geeek-a1-mini-itx-case-pre-order-pricing,40084.html

Thanks!

I’ll be interested to read Brave’s response.

My experience: this behavior — video autoplay with or without sound despite trying to block autoplay within Brave’s settings — occurs on many websites. The instance on the website you mention — tomshardware — is typical, not unique. It appears to be related generally to Chrome and not specifically to Brave’s implementation of Chrome.

Through Brave v0.66…, one could type in the Address Bar (or cut and paste): chrome://flags/#autoplay-policy

Click Enter. In Brave, the URL automagically translated to brave://flags/#autoplay-policy

This brought you directly to a flag that could be edited. From the drop-down box, I changed the setting from Default to “Document user activation is required” and relaunched the browser.

But…

Implementing this change didn’t entirely resolve the issue.

And…

In Brave v0.67… this flag is no longer there. Gone. Disappeared.

Which is to say: the problem you report — uncontrolled video autoplay — is very real. It appears to be an issue with Chrome, but if you’re using Brave, that’s merely a deflection, not a resolution.

Sorry I can’t be more substantively helpful.

No reply from Brave folks???

While I cited only one particular sites, there are many many many sites that autoplay videos, even when site settings are altered to block video autoplay. Usually they are news sites like newspapers and tv stations.

HOW can these annoying behaviors be blocked? (without adding yet another plugin?)

Thus far, Brave folks have been mute. (Unlike the random video autoplay…)

I agree with your description. My 3 Aug 2019 reply was mainly to emphasize: out-of-control video autoplay is general and not specific to the website you mentioned.

Further, I think Chromium (Brave’s underlying engine) regards disabling user control of video autoplay as a feature, not a bug. Selling advertising, it’s referred to as boosting “user engagement”. That’s not my euphemism; it’s theirs.

What to do: I have multiple browsers installed. I select amongst them depending on what I’m doing on the interwebs. Some browsers are much more respectful and considerate about providing users with choices. And considering this is a Brave community forum, that’s about all I’ll say.

Bumping this, for a few reasons.

First, thus far, there’s been no response from Brave.

Second, with Chromium’s eliminating the #autoplay-policy flag option, I installed “AutoplayStopper” a 3rd-party extension: so far, so good. AutoplayStopper doesn’t completely stop video autoplay in Brave – and why some video content continues to autoplay is not apparent to me – but Autoplay Stopper greatly reduces the problem with no apparent unwanted side-effects.

Last, a few days ago Firefox released v69.0 which offers control of video autoplay. Giving users choices is a really good idea.

Still no Brave response…
Yes, AutoplayStopper certainly helps. Yet, I was hoping to not resort to yet more extensions.

So… How well does Firefox v69 block trackers and advertising?

I don’t get any autoplay on the link despite having no extensions. Agree autoplay is super annoying but so far Brave browser works like a charm for me.

If I understand correctly, whoever creates chrome is intentionally removed the ability to prevent video autoplay.

It is common sense to suspect such decision has “evil” intention: forcing user to watch ads (plus waste their internet quota). Thus we can’t trust chrome.

And if chrome is no longer trustworthy, can we trust Brave that use chrome as their engine?

@guh,

  1. Google creates Chrome. And no, they didn’t remove the option to block autoplay content.
  2. Chrome =/= Chromium. The Chromium project is an open source browser engine used but many other companies. The difference is that Brave goes the extra mile to remove any/all Google code from the engine to ensure the privacy/integrity of your data..
  3. This issue with Autoplay is known and currently being worked on – please note that you can still block autoplay in Brave, and for many users it works without issue. Unfortunately, whatever is causing this particular issue makes it difficult for some users. Please read through the Github issue and try readjusting site permissions to block autoplay content.

Thanks for the link to the GitHub “Autoplay is not blocked #5605” thread which was opened on Aug 9, 2019. @bobeaston created this topic on Aug 3, 2019. Perhaps a change to Chromium subsequent to Brave v0.66… — a change which eliminated the flags/#autoplay-policy, and with no autoplay-policy flag, no user ability to edit user choices — resulted in this unwelcome behavior.

Bottom line, ex Brave v0.66… I’ve found that without installing the AutoplayStopper 3rd-party extension, there’s no way in Brave to universally squelch Autoplay. AutoplayStopper isn’t entirely successful at this, but it gets most of the way there.

(Yes, I’m somewhat aware of the distinction between Chromium and Chrome; I’ll try to be more careful about this in the future.)

@redbike9

This actually isn’t accurate – you still have controls within the default UI that allow you to select how you want Autoplay to behave (both overall and per-site), but due to issue #5605, they’re not quite working the way they should be. I’ve added @bobeaston’s and your reports to the thread as a +1 on your behalf.

For what it’s worth, regarding the #autoplay-policy flag – we (Brave) did not remove this flag, it was removed in the Chromium code which we then inherited.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.