Close, minimize and maximize icons aren't in their correct position; they are too low

Description of the issue:
With a recent update of Brave*, Use system title bar and borders being off in Setting causes the close, minimize and expand icons/buttons to fall below the title bar and into the main site area.

*this wasn’t happening before a recent update; I always had it set this way, without title bar and never was it an issue.

The following image is a screen shot of the issue (seen when Use system title bar and borders is turned off)

And this is how it looks when the title bars are turned on and the icons are set into the now exposed title bar (you can see it’s now using the system title bar and theme):


Disabling extensions, checking in private window and changing from Classic, GTK or QT theme or switching to light/dark colors does nothing to address the issue:

I also tried uninstalling and reinstalling, with no change.

How can this issue be reproduced?
I’m not sure it can, unless others are experiencing this as well but…

  1. Go into Settings > Appearance and see if Use System Title Bar and Borders is off and check if the icons are in the correct spot or not.
  2. Turning this feature on adds the system title bar and the icons are set in said title bar as expected.

Expected result:
Expected the icons to stay in their appropriate position when no title bar is present i.e. they shouldn’t be so low on the screen.

Brave Version( check About Brave):
Version 1.60.110 Chromium: 119.0.6045.105 (Official Build) (64-bit)

Additional Information:
Operating System: Manjaro Linux
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.111.0
Qt Version: 5.15.11
Kernel Version: 6.5.9-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 5800X 8-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: AMD Radeon RX 570 Series
Manufacturer: Micro-Star International Co., Ltd
Product Name: MS-7B86
System Version: 3.0

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.