When maximized, brave does not respect screen bounds

Description of the issue:
When maximized, brave allocates space for and draws the scrollbars off screen (linux, bullseye, MX). Other windows, such as term, draw scrollbars inside window space, within limits of screen space.

How can this issue be reproduced?

  1. Using a site with page content that exceeds screen space, which requires scrollbars to be needed
  2. Maximize the browser, see that scrollbars are not displayed. In my case, I have dual monitors. When using the left monitor, you can visibly see the scrollbar being drawn on the right screen’s space. When same site is on the right, the scrollbars are invisible (being drawn off screen). A slight pull down to keep screen just below max, but not maximized (using 95% desktop feature) scrollbars are displayed in browser correctly.
  3. While this is going on, actual scrolling via mousewheel, tab, or arrow keys is not affected.

Expected result:
When maximized, brave should respect screen bounds.

Brave Version( check About Brave):
Version 1.31.87 Chromium: 95.0.4638.54 (Official Build) (64-bit)

Additional Information:


In addition, using fullscreen (F11), scrollbars are correctly drawn.


I have a very similar issue on Arch Linux using xfce. F11 full screen works fine for me, but when maximized the scroll bar bleeds out of the screen on the right, and the top of the window bleeds out of the screen making it difficult to click tabs and the minimize/maximize/close buttons.

Using 1.31.87 Chromium: 95.0.4638.54(Official Build)(64 bit)


Same here with Linux Mint



I have the same issue with manjaro xfce. The top, left and right parts are cut off when browser window is maximized. Scroll bar is invisible on websites. Full screen fixes the scroll bar issue.

1 Like

Manjaro XFCE here - this is very noticable on a multi-monitor setup where the edge of the browser spills into the bordering monitor space and sits overtop of the edge of other windows. The irony in this case is that the “Reply” button to submit this response was nearly completely off the bottom of the screen.

Version 1.32.71 Chromium: 95.0.4638.50 (Official Build) beta (64-bit)

1 Like

Just a note, Google Chrome, version 95.0.4638.54 (Official Build) (64-bit) does this exact same thing, so it might be an issue with the chrome/chromium engine.


Same on Version 1.31.87 Chromium: 95.0.4638.54 (Official Build) (64-bit), Linux Mint XFCE

1 Like

Debian XFCE here, the only way to fix now is right click at the Windows top and check “Use system title bar and borders” and then uncheck it.


Thanks, same here in XFCE with Artix, but now I at least know how to change the window size.

1 Like

Lot of weird display issues on Linux being reported here lately, across many threads including this one.

Anyone want to try Brave Beta and see if it goes away? I agree it’s probably a Chrom(e|ium) 95 issue.

Brave Release 1.32.x is due in Nov and will be on Chromium 96, it will be interesting to see if the issue is likely to self-resolve then.

1 Like

Seems the browser is adding/including drop shadow as window dimension and ignoring user UI/WM preferences about things like drop shadow.

1 Like

I swapped to KDE today from XFCE and the issue resolved, with all else remaining the same. Based on the replys with the desktop environment being noted, this may be specific to XFCE


I’m having the same problem on the new MX Linux 21 Xfce, based on debian bullseye. To turn around the problem, I’m using f11 or checking the option “Use system title bar and borders” when right-clicking at the top bar of Brave window.


Same here in Manjaro XFCE. Reiterating to avoid closure of this topic.

1 Like

This was posted earlier, but maybe it got missed.

It’s looking more and more like this is a known issue when running under Xfce: Brave opening with "invisible borders" that "break" the previous size *UPDATED* v1.30.86 => v1.31.87

There’s a bunch of active threads on here about this right now.

My main desktop running Xubuntu 20.04 just started doing this nonsense with Brave Browser today.

It has Brave Browser: Version 1.31.88 Chromium: 95.0.4638.69 (Official Build) (64-bit)

My laptop is also running Xubuntu 20.04, but has Brave Browser:
Version 1.31.87 Chromium: 95.0.4638.54 (Official Build) (64-bit)

This system does NOT do this nonsense with maximizing the Brave Browser window.

I had the following versions in my apt cache directory:


I back-leveled first to v1.31.87, problem still persisted.

Then I back-leveled again to v1.30.89, the problem is corrected. Brave Browser window maximize does not go under the XFCE top panel any longer.

TL;DR: Chromium 95 bug. https://bugs.chromium.org/p/chromium/issues/detail?id=1261874

Seems that this issue only occurs only on xfce.
Chromium 95 bug report: https://bugs.chromium.org/p/chromium/issues/detail?id=1260821

1 Like