The browser becomes so slow

Hello

The browser becomes so slow, especially in startup.

Try turning off “Use hardware acceleration when available” from the Settings screen, under System.