Stop New Tab Page Displaying Google Search History

Clicking in the Address Bar on the New Tab page shows my Address Bar Search History (where I’ve typed something directly into the address bar). Why does it do this? I don’t want it popping down with a load of visible stuff that I’ve searched for.

It ONLY seems to do this on the New Tab page:

My Settings:

1 Like

Hello @BobT36

could you go to brave://settings/privacy

and disable this Autocomplete searches and URLs

hope it help and have a nice day

Hi mate, unfortunately, that one was also already switched off:

As mentioned this ONLY happens on the new tab page. Clicking in the Address Bar (even when empty) of a normal loaded tab does nothing, but on the new tab page it does this, which could potentially be very exposing lol:

I can mouse over each and click the “x” next to each row to clear it, but the next time I click, older results are then displayed so I’d have to clear EVERYTHING I’d ever typed.

Seems to be something to do with Google Search History. I can’t see any settings for this, though?

i tested it with google and duckduckgo as default and i get the same result as you

the only thing i get till now is to clear this one from the cache setting
go to brave://settings/clearBrowserData

check all time and check browsing history only

and if you use private mode it does not show up unless you already used the same word in normal mode

but not sure if there option in the setting to disable this behaviors

and have a nice day :slight_smile:

Cheers mate, good you’ve been able to replicate it. Seems this is a bug, then?
Should I get this topic moved to a different section.

I’m ok with keeping normal history, as I need to make an intentional attempt to view that. But I don’t want anything being kept in my address bar that might pop down and be unintentionally seen by anyone. Clearing it all the time would be a pain.

first i am not sure if it a bug or they intended to do it or there some option i missed that would help to make it work as you like

or it even considered a feature request so wait tell the team back tomorrow and see what they can offer for that

and for this

you can use normal mode as you like and when you want to search for something that you do not like to keep try to use private mode it will only show the thing from the normal mode but any new search in private mode would not show up in normal mode

and have a nice day
not sure if that could be intermediate solution or what

Yeah I’m thinking it’s a bug, considering this ONLY shows on the New Tab page. I suppose the address bar drop-down / history should be switched off for everything via the options we posted.

for me it show up in both the new tab or any tab

could you help us here @Mattches

and have a nice day both of you :slight_smile:

Interesting, for me it ONLY pops down on the New Tab page.

Even if I blank out the address bar and then click back in it, it doesn’t show up on any other tab.

finaly i got it

i recheck all setting

and i disabled this Show autocomplete in address bar and now it does not show up in any tab or new tab

i know from your screen shoot you sent that it already disabled on your side

so could you try to create a new profile just for testing and see if it work the same as me or you still face the same issue
and do not forget to change the setting on that new profile also :slight_smile:

hope that help and have a nice day :slight_smile:

Hmm nope I got the exact same behaviour, with it only showing on the New Tab page.

let me share with you all my setting to see what we missing here

i know many of the following setting is not related but let us see how it go

all setting in brave://settings/autofill disabled also

so double check it with your settings them if there any difference then apply them one by one till you get the one that we could missed

try this setting on the new profile you created so you did not miss with your old profile

the only differeance between me and you after apply those settings that i am using linux and you use windows

hope that help and have a nice day

Cheers mate. Other than linux / windows, all my relevant settings are similar to yours.

However the difference is the Search Engine. You use DuckDuckGo, I had Google.

Now if I changed it to DuckDuckGo, it does NOT pop down the history on the New Tab page. Changing it to Google, typing something, then checking new tab causes the behaviour in the OP. Seems it’s a Google only thing?

i tried and set google as default and it work fine

are your test was on the new profile right?

Yeah. As soon as I set from DuckDuckGo to Google it cleared it. But then when I typed something in, went to the new tab page and clicked in the Address bar, down it popped again with what I’d just typed, along with “Test” and “TestSearch” or something, (presumably what Brave uses internally when it gets set to use Google.

i meant that it work fine for me even when i used google as default

Yep, just double-checked. Made a new profile, set it up EXACTLY how yours is in the screenshots (with DuckDuckGo as search). Searched, went to new tab, nothing. Changes ONLY the Search Engine to Google, and boom, it now shows history on New Tab.

Also it’s not only the Address bar / URL history, it’s ANYTHING I TYPE INTO GOOGLE. Even if I manually go to and search from there, whatever I search for shows up in the New Tab pop-down:

However I’ve also worked out this ONLY seems to do it for Google UK. Maybe it’s something to do with my URL string?:


Wouldn’t have thought that would matter though if I’m searching DIRECTLY on Google, also why does it ONLY do this on the New Tab page? Surely that part is dodgy on Brave’s end.

the weird thing that did not happen to me even with google set as default

try to update as they new version release today and see if it help or not

is it Google.Com you’re using tho? I think it might not be a problem with other variants.