Stop New Tab Page Displaying Google Search History

Technically, that’s not called an “address bar” … it’s an “omnibox” : )

There’s been a flag setting for Chrome as follows:
chrome://flags/#omnibox-zero-suggestions-on-ntp

“ntp” in there is an acronym for “new tab page”

I don’t think Brave has this flag … or if it is a flag in Brave, it’s been renamed.

So, this flag is no longer in my version of Chrome Dev (and Chrome Release) on openSuse Linux.

It’s now found via Settings -> Sync and Google services -> Autocomplete searches and URLs … disabled turns it off. (Chromium has it too).

Brave (Nightly and Dev on my desktop) has the Autocomplete searches and URLs toggle within Settings -> Privacy and security (see (a) screenshot)

HOWEVER, this setting on Brave does not have the same effect. (see (b) screenshot) … it still shows typed history in the omnibox.

(a)
image
.
.
(b)
image

Ah-ha thankyoufor getting to the bottom of this mate. Good work.

First time I’ve heard the term “omnibox!” :laughing: Making me feel old now, browsers are getting a bit silly with all this integration. One reason I always used to use IE was that it was just so simple! Since Brave still doesn’t have a Menu Bar, I only switched cause everything stopped working well with IE as soon as it went out of official support.

What really gets me with this problem is it showing EVERYTHING you’ve typed into google, no-matter whether it was directly into the “Omnibox” or Google’s search directly on it’s web page. Increasingly dodgy is that I have all search history storage etc in Google itself turned off! So where is this data coming from?

Brave as a Privacy Browser really needs to address this one. The fact it only appears on the New Tab page says to me that this is unintended.

Happy someone else has been able to reproduce it. Any way to flag it to the devs?

thanks @caldercay

the wierd thing that i shared with him my setting and then i set google as default search engine and i do not have that

looks like google fear me looool

do you login to any google service when you use the browser

do you keep your cookies after using google service or clear cache

Yes and no, normally.

However I just re-made the 2nd profile, ensured the autocomplete was set to off, and just told it to clear browsing data on exit, and open new tab page rather than continuing where left off. The Search data (even that typed directly into Google.Com rather than the “Omnibox”) was retained in the drop-down on the New Tab. This is despite not being signed into Google on that profile!

I’m presuming Brave itself must be tracking ALL Google Searches and retaining that data, and displaying it only on the New Tab page for some reason (likely unintended). Hopefully they implement the option that Caldercay mentioned that should fully disable it.

Btw justsomeone1, when you say Google doesn’t do it for you, WHICH google are you using, and what’s your search URL string? I posted mine above.

by the way i created a new profile and and left everything only change this setting
Show autocomplete in address bar in the apperance setting

and used google and default

the setting in the search engine page as follow

Search engine Google
Keyword :g
url {google:baseURL}search?q=%s&{google:RLZ}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:iOSSearchLanguage}{google:searchClient}{google:sourceId}{google:contextualSearchVersion}ie={inputEncoding}

i did not change any of it so it’s the default after creating that new profile

and have a nice day :slight_smile:

Does that go to Google.com for you tho?

And I wonder, must be the Linux version why it’s not doing that for you. I’ve updated to the latest Windows Brave version and unfortunately it’s still doing it.

but @caldercay said he has the same effect as you and he is linux user also then maybe i am the one who has the issue loool