How do I turn off the search suggestion in the address bar

As per this image the old searches are turned on but I cannot find the option for disabling that.

I have turned off Settings > appearance > “Show autocomplete suggestions in address bar” options and Settings > privacy and security > “Auto-complete searches and URLs” but these did not help.

Any Ideas?

Steps to reproduce:

  1. launch brave.
  2. open a new tab.
  3. click on the address bar
  4. observe that the old searches appear as suggestions

Expected/preferable observation:

  • Clicking on the address bar does not show previous searches
  • Clicking on the address bar does not show previously visited URLs
  • Clicking on the address bar does not show any kind of menu.

Version 1.48.167 Chromium: 110.0.5481.104 (Official Build) (64-bit)

Hello @Debagnik, thank you for reaching us out. Have you tried deleting cookies and cache recently? Do you use extensions? If so, might be some of them is interfering on the search bar functionality. Hope it helps. Regards.

Thanks for taking the time to help me here.
I have tried deleting the cookies, but the issue didn’t resolve.

the list of extensions I use is as follows:

  1. Absolute Right click enable
  3. Bitwarden password manager
  4. Google Translate.
  5. Grammer checker
  6. SAML-Tracer

I use all of these extensions on a different machine, but there the search bar works as expected.

I tried clearing caches, but it didn’t help.

I have mentioned additional info on another comment but it has been flagged as spam by Askimet bot.

Hello again @Debagnik, I just saw your reply is hidden for any reason. In case you are using some extensions try removing some of them or one by one to see which one might be causing the issue. Also you can try in a private window or creating a new profile. Let us know if the issue persists. Regards.

I am having the same issue. This is really bad for a Browser who promotes itself as the best option for privacy and security.

And it is even worse, if you press “Shift Delete” while on top of the suggestion the normal behavior is to delete. But it will eventually come back. Really really bad.

I assume there is somewhere a cache of the “Browsing History” inside of Brave. Because I even went to google itself and deleted those suggestions and now they do not show up anymore in Google but the continue showing up in the address bar.

Hello again @Debagnik, I am following up this case. Is this still an issue for you?

Hi @Jarc-1107
Sorry for the late reply,
Yes this is still an issue for me

Please note that I had previously mentioned this is not an issue on my other machines, But now I am checking on my different devices this issue exists there as well, as far as I remember this didn’t use to happen.

Troubleshooting steps I did:

  1. Removing extensions.
  2. Clear browsing data, caches
  3. Using bing and brave as the default search engine

Result Observed:

  1. Removing extensions didn’t make much of a difference
  2. the search bar was empty at first but started suggesting previous searches as I started using more and more.
  3. I am yet to observe enough differences to make a conclusion after the search engine change, I will keep you posted.