Page rendering issues in Brave for the last month or so

Description of the issue:

A video is worth 1000 words

But here are some words anyway: Several times a week, the contents of a webpage will either (apparently) disappear or (apparently) fail to load — but when I start dragging my mouse around, elements appear underneath the arrow. If I drag around enough, eventually all the elements of the page will appear.

It usually happens only in one tab at a time.

It’s happened across a wide variety of websites.

Sometimes reloading the page helps, but not all the time.

Sometimes on pages that have rendered successfully, when I mouse around, elements disappear instead — usually, but not always, on pages that had originally failed to render.

How can this issue be reproduced?
Haven’t been able to reliably reproduce it, but it’s been happening randomly, several times a week (I’m actively using Brave 40-50 hours a week), regardless of which profile I’m in, including profiles without any extensions, and including when incognito.

Happy to provide additional info upon request. Can dive into Developer Tools if helpful.

Brave Version( check About Brave):

Additional Information:

1 Like

i have this issue too but only with OpenGL activated, it happens on Youtube and Twitch, no other browsers has this issue even with opengl activated, sadly only opengl works properly good against the chess visual glitch from the chronium apps and i don’t want to change browser, lets hope and wait for a fix.

Just checked brave://gpu, and OpenGL is disabled for me, so that’s not it — at least not on my end.

I have this problem. Windows 11, custom desktop computer, rtx 2080 ti, i7 12700k, 64gb ram

I also have it happen in a Ubuntu VMware VM. It’s super frustrating. This has only been occurring recently (past few months)

  • Posted in another thread too

Doesn’t look like this has been seen by the team.

@Mattches ?

@100WattWalrus Let me ask a series of questions here really quick, especially since I know might be things Mattches and others likely will want to know and verify. (first two kind of confirming what you already said)

  1. You’re saying this happens in normal profile, in private, and even in a new profile with no extensions?

  2. This doesn’t happen on any particular site or content types?

  3. Have you tried disabling hardware acceleration?

  4. Have you noticed if disabling Shields makes any impact? (if you have any custom filters, try removing them and test. They persist through profiles)

  5. Have you tested on Brave Beta or Brave Nightly?

  6. Does this happen in Chrome?

  7. Have you made any attempts to reset your graphics card and/or to update drivers?

  8. Have you made any changes to brave://flags? (if so, keep in mind they persist across profiles)

  9. Which version of Mac are you using?

1 Like

The problem is intermittent, so it’s hard to say for sure about all these circumstances. When it’s happening in one profile, it’s not usually happening in others at the same time — but it’s not profile-specific.

But I will try to recreate incognito and in clean profile, and get back to you.

I’ve noticed it most on (pane showing list of emails often looks empty until I mouse over), and (as shown in video).

Already disabled.

Not yet. Will try this too.

Nope. But it’s been going on for a month or two, so I’ve had a Brave updates or two since it began.

Not that I’ve been able to reproduce.

Nope. But I’ve never had to do that on a Mac. :slight_smile:

Pretty sure no. I’ve poked around in flags a couple times when there was something specific I wanted to do, and found suggestions online for flags to fiddle with, but I’ve ended up bookmarking those for future reference rather than pulling the trigger. They are all currently Default. But if there is a flag I’d set, it would have been months ago, and I would have made a note of it, which I don’t find.

2020 M1 MacBook Air

1 Like

@Saoiray two additional data points (not sure how helpful they will be by themselves):

  • The problem seems to occur on a per-tab basis — either that or once I’ve moused around and the page has re-rendered, it’s solved for all tabs until the next occurrence
  • Reproduction has been too unreliable to say with any certainty if it happens with no extensions, but it’s definitely happening with extensions that shouldn’t affect page rendering to this extent. One profile where it happens a lot has only Enpass (password manager, for which I have in-page pop-ups disabled) and AutoplayStopper (shouldn’t affect pages without video at all).
1 Like

What’s crazy is extensions can mess with all sorts of code within the browser. Even producing the craziest things you would never expect. Ideally we’d have you focus on a new profile and avoid the extensions. Then see if you can end up reproducing the issue. If it never appears, then might suggest it’s one of them. At which time you could only add again to see if the issue returns or what happens.

It stinks how there’s no quick and easy answer on it. But it’s especially more difficult when it seems random and can’t reliably be replicated. As frustrating as it may be, this might be the direction to go if you’re willing.

Oh, well then…it would be the opposite! lmao. I’m sure you’re aware, but using hardware acceleration lets tasks be divided up between your CPu and GPU. Typically things run much smoother and puts less demand on your device. Generally this is a good thing and you want it enabled.

We just tell people to try toggling it off because if the issue goes away, it suggests it could be a graphics issue. Whereas if it persists, it likely is something else. If you already had it off when experiencing rendering issues, we just would want to confirm if the opposite is also true. If hardware acceleration on has no issues, then you’d want to leave it on and it might just be that you need the help from the GPU for things to go smoothly.

Just to circle back on this, even the most innocent seeming extensions have caused browsers or computers to crash, have artifacts on screen, cause devices to overheat, etc. I know a while back someone had a D&D dice rolling that was a problem. Then on another, they had a YouTube extension but found it was causing the browser to lag everywhere they went. List goes on. So yeah, have to pretend each and every theme or extension installed might actually be a culprit until can rule them out through troubleshooting.

So basically, script heavy content. The name AutoplayStopper is enough to make me think it could potentially have an impact on these sites you’re mentioning. Essentially some confusion where it’s seeing script that is trying to play content (load your emails, videos, etc) and it’s stopping them.

Doesn’t mean it’s happening, but I guess seeing you mention it along with where it’s seeming to occur the most, it kind of seems like a big possibility.

I have this problem. Ubuntu 22.04.3. It happens frequently when access gitlab and amazon page. This issue occurs using incognito mode as well.

Just out of curiosity for a moment, do you happen to have an extension like AutoplayStopper or Enpass?

@Mattches and @steeven just wanted to tag you both in on here. Hoping perhaps you can chip in with some ideas before the end of the day, since we’re heading into the weekend.

Yeah this is a super strange issue. Definitely seems like it would be HWA on the surface — @100WattWalrus I am curious to know if toggling it “on” makes any difference.

Its unfortunate that the issue occurs so inconsistently because I’d really like to narrow down whether or not it’s cause by an extension or not.

I’m going to open an issue for this regardless — thanks again to @100WattWalrus for providing such detailed reporting, it will make this much easier to file — and see what the rest of the team thinks.

1 Like

Issue opened here:

No. I disabled all extensions, but the problem persists

Thanks for the detailed replies. I’m going to try turning on hardware acceleration, and if that doesn’t help, I’ll try turning off AutoplayStopper.

BTW, I have this extension mostly because Brave’s built-in stopper prevents Vimeo videos from playing at all (have reported that separately), and doesn’t have the option of turning it off for a single session — it’s an all-or-nothing affair.

Happy to help. I’ll turn HWA back on and reply in a couple days with an update.

1 Like

@Mattches @Saoiray
I’m back two weeks after turning HWA back on. Haven’t had the rendering problem since. But FYI, Brave is definitely using more juice than it was with HWA turned off.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.