Once again Brave won't play videos

Most of the sites I go to are not YouTube connected, but it now seems that almost all videos refuse to play. Bitchute, Odysee, etc., and private websites as well. I finally switched back to Firefox because of the problem, but I’d like to be using Brave.
Brave Version 1.34.80

On my end, videos on all these sites are working as expected.
Can you please explain more about the behavior you’re seeing when you try to watch videos? Does the video start then freeze/stop? Does the video load infinitely? Is the rest of the site responsive?

Additionally, do you have any extensions installed in the browser at this time?

1 Like

Nothing happens. I click on the video and it just sits there.
Currently, the only extensions I have on Brave are LastPass and Bitwarden. (Bitwarden won’t sign in properly on Brave so I’m still using LastPass.).

I have disabled Google logins on third party sites and social media.
Widevine is turned off. Could that be the problem?

I am having the same problem with videos. Youtube TV won’t play anything - error is Unsupported video format. All other browsers work fine.

I might add that regular youtube videos play just fine.

So today, without changing any settings, videos are now playing. Why? I have no idea. What I know is that this is an intermittent problem. For several days videos will play fine, then suddenly they won’t play for a few days. No rhyme or reason that I can find.

I can reproduce this. go to fox2detroit.com click on any story with a video it won’t play. I would love to use brave however this is an issue that should be fixed.

The thing that is so maddening about this issue, at least for me, is that sometimes videos will suddenly decide to play, maybe for an entire day. The last time I posted, they were playing. The next day, not at all. And what’s odd is that when I click on the “play” icon, I’ll get an indicator that the video is loading, and then–nothing.

As you said phoneman1011, none of the videos on that page will play. I can play them in Firefox, so until and unless this issue is fixed, I’ll be using Firefox for all my videos, which means that because I’m already on FF, I’ll probably just do everything else there, as well.

I tried to find how to do a bug report, because I suspect this is not the place to do it. Does anyone know how to file ta bug report for Brave?


I agree with you. The videos play fine in FF and Edge. This is clearly a brave issue. Compound that issue with no reader view in windows brave is getting lower on my list of Browsers I will use. I would love to be a brave user. I like the privacy and such that it provides however I watch Fox2detroit.com often if I can’t watch that or other videos it’s a nonstarter.

I couldn’t get Twitch.tv to play. If I unblock auto-play it works. Not sure if that’s a good idea. Would be nice if I could block auto-play and make an exception for sites. But I don’t see that option. I only see the opposite option, allow auto-play and 2 sections (for some reason?) to add exceptions to block sites.

Interesting. I also unblocked auto-play and suddenly the videos worked on sites where they’d previously just sat there doing nothing. How is that supposed to be a solution? Not wanting autoplay doesn’t mean not wanting any video play!

Come on, Brave developers! This needs to be fixed!

Okay, time to back-pedal. I allowed autoplay on individual sites and they work. The sites where there is no option for autoplay (such as phoneman2022’s mentioned site), the videos don’t play.

I looked for an autoplay setting in Brave settings, and couldn’t find one. Am I missing it?

It’s hard to find. Settings/Security/Permissions/additional permissions.

Hmm. I’m not finding that. The only place I find “Additional Settings” is under the first Settings heading. Other than that, I have
Settings>Security and Privacy>Security>(nothing to do with permissions or autoplay)

I left out something.
Settings/security/site and shield settings/additional permissions

I’m not sure what auto-play does. If you are limiting what scripts a site can run, does auto-play ignore that and just let everything run?

I’m not sure either. I would have thought autoplay would merely stop one video automatically playing when the last one was done. Instead, it seems to stop playing of any video whatsoever.

Thanks for the update, btw. I changed the permissions and now I’ll see how it affects video play on various websites. Hopefully, my next report will be hopeful.

Sorry for disappearing here.
@rosawoodsii please let me know if changing the autoplay permissions for the relevant sites works.

I had turned on autoplay for everything and it worked as expected; i.e. even if I didn’t want the next video played, it played; even if I didn’t want videos to play automatically when I opened a site, they played. So, I blocked autoplay and I’m able to get video by clicking on the video start button–so far.

I will leave this thread open for now — please let me know if the behavior reverts back again.

Thank you.

I’m still getting odd behavior. I have autoplay OFF and have added one site to the exceptions. That site works great. Other sites that are not added to exceptions also work great, but not all of them. As I come across sites that refuse to play, I’ll add them into my exceptions list. That list is definitely a plus, but the fact that with autoplay in the OFF position, some sites refuse to play altogether (unless added to the exceptions) and other sites work fine is still baffling. There seems to be no rhyme nor reason to which sites work and which don’t.