Video will not play


Description of the issue:

Can’t play any videos. Embedded in Twitter or YouTube or news channels.
How can this issue be reproduced?

  1. Open YouTube or Twitter and try to play a video.

Expected result:

Click on video and you only get the first couple frames then it stops.

Brave Version( check About Brave):

Version 1.19.88 Chromium: 88.0.4324.96 (Official Build) (64-bit)

Additional Information:

Platform ServicePack Version VersionString


Win32NT 10.0.19041.0 Microsoft Windows NT 10.0.19041.0
Windows 10 Pro
Surface Pro 4

I disabled hardware acceleration and removing all extensions as suggested in a post I found here in Brave community. No change.

@in01902 ,
Are you unable to play videos on Youtube or Twitter directly, or are you saying that there are sites that embed Youtube/Twitter video content that you’re unable to stream on that site?

Directly on Twitter and YouTube. Another example is video on this site. https://whdh.com/ But yet on this site they work. https://www.wcvb.com/article/developing-noreaster-could-bring-significant-snow-next-week/35360938

I have also dropped shields. All other browsers work find but just incase I disabled my PiHole. No change.

just tested both whdh.com and wcvb.com. Was able to stop/start and adjust volume controls. Is it still an issue @in01902

It’s still happening but… This one works. https://twitter.com/BostonPWD/status/1356372626814496768?s=20

This one does not.

Here is Youtube. Press play and it moves a couple frames then freezes.

Can you re-test in private window mode? does it play back okay?

1 Like

Too funny. I just did that right before I got your reply.

I have the same issue. Sometimes it will play for a bit before it happens, but it happens nearly every time. I’ve experienced it with Facebook videos, webinars, Youtube. Every source of videos seems to have the same problem with stutters, freezes, etc.

If I switch to Chrome I have no problems. But on Brave, I have problems almost 100% of the time with video.
Current release of Brave, Windows 7 Pro. Plenty of available RAM and CPU.

Check More Tools - Task Manager to see which tabs and extensions are causing excessive cpu usage. @JerryC

Usage seems to be okay here @in01902

I’m on Windows 7. I don’t think I have the tool you mention in Task Manager. I don’t think it’s a CPU issue however. My CPU is only at 12% usage total. The highest Brave service is running at 4% CPU load usually. When I play a video in a tab total CPU increases to 40%image

Brave has its own task manager, (see screenshot) @JerryC Will will show which tabs/extensions are using the most resources.

Ah, sorry. Thank you. Got it. I pulled up a video (in this case in Facebook because lets face it, Facebook is a hog. I do see the FB tab is sucking up a lot of CPU as expected but I don’t see any extensions out of place.

I don’t want to hijack this thread. I just thought maybe we were both suffering from the same cause.

About to head off to bed, But looking at the above screenshot, Facebook is causing the issue there.

Having videos on display/autoplay Facebook will cause excess cpu… As a quick test, on a static Facebook page (no videos), I’m getting 0.0-2.0% cpu usage.

Apart from Facebook sucking, cpu Its not too bad.

Agree that FB is bloated but the video issue exist in every page, not just FB. For example here’s the dump while a Youtube is trying to play. The same thing happens on new pages, webinars, or any page with video. They play fine in Chrome so it’s something unique to Brave.

So my point is that it’s not just a FB issue. It’s a Brave issue. EVERY video has the stuttering issue in Brave regardless of the source. It’s so bad that I’m forced to change to a different browser to play videos.

I’ve seen some issues where a user’s monitor was in 1080p or 4k mode. What mode is your monitor in? Can you try this on a different computer where the OS is the same version but the monitor is in a lower resolution?
Let us know what you tried and how it worked. Also:

  1. Check your anti-malware package and allow all traffic for Twitter.com and Youtube.com. Does that help?
  2. Do the same for your firewall software, like MS Firewall. Does that help?
  3. I do not see your connectivity type. Is it wifi? Wifi can cause some problems if there is a lot of usage in your house or there is local interference with the signal. That’s why I use ethernet cable. Leaving all other variables the same, try connecting your computer via a physical cable.

I tried your link about the Worst Excavator Recovery and it worked fine. I’m on Windows 10, display is 1680x1050, and I have an Nvidia Geforce GTX 1060 which uses STUDIO drivers, not the game drivers. The game drivers can be unstable.