Youtube movie(free with ads)

Why cant i watch youtube movies with Brave browser( i get " Your browser can’t play this video.")

Is there a way to fix this or does Brave browser just not work with youtube moies?

@Brutus22 you always need to advise which OS and version of Brave you’re using, as answers change depending on what you’re using. For example, if you’re on Desktop it may very well be that you need to go to brave://settings/extensions and enable Widevine. However, that option doesn’t exist on Android or iOS.

The other thing that is important would be to share a link to a video you are trying to play. This allows others to test to see if they can replicate the problem. If they can, it makes it easier to identify what’s going on.

In any case, always try to provide as many details as possible.

im on a desktop- windows 10- I did this already: brave://settings/extensions and enable Widevine- that didnt work.

It was on any "free with ads" movie on youtube. I get the "Your browser can’t play this video.
[Learn more](" message on the video screen. Regular youtube videos play fine.

But here are a few links to the movies" that wont play:




@Brutus22 I just tested on Windows and all those links played. The only time I got your message, which is in screenshot below, is when I turned off Widevine.

If you have it enabled as it is below, shouldn’t have problems. (also keep in mind once you flip the toggle, you have to relaunch the browser)

If you still are, then I’d ask you to do the basic little troubleshooting things we tend to do to rule out things like bad cookies, extensions, etc. Those same thing we tend to ask many people to do are (Do each step separately)

  • Open in Private Window. Does it work there?

  • Create a new browser profile (don’t add extensions or change settings). Does it play?

Oh, I also want to ask, which version of Brave are you using?

I have my settings exactly like yours in the photo. i still get the “Your browser can’t play this video” message. I had it set this way yesterday and it worked, but today, its not working.

im using the most recent Brave version :

  • Brave is up to date
    Version 1.52.122 Chromium: 114.0.5735.110 (Official Build) (64-bit)

I opened in a private window - still get the “Your browser can’t play this video.” message

I created a new profile with no extensions and correct extension settings- i still get “Your browser can’t play this video”

@Brutus22 I wonder. Do you have VPN enabled each time? If so, what happens if you turn off VPN? I’m wondering if they are blocking because of that.

When I went to search whether this is the case, Google’s AI generated response was:

If YouTube identifies your temporary IP address as one issued by a VPN provider, you’ll be blocked from streaming content.

I know someone had experienced something similar with Netflix recently. So just has my curiosity here.

i do not have a vpn enable/turned on

i even turn Brave Shields off and Ad blockers

Like i said, i can watch any video, just not the “free with ads-Movies” on youtube.

Im just confused, because i turned on Widevine yesterday when i found the solution and it worked, but today, its not working again even with it enabled. I turned it off then relaunched, then back on and relaunched- still no fix

i cleared my cookies and cache, i cleared old registry, and i rebooted my computer- did work

oops, i meant didnt work with cookies, cache and reboot

Ah, my bad then. Looked like I saw VPN on the upper right of your browser enabled. But maybe it’s just me seeing it wrong and it’s in the inactive state.

@Mattches @steeven you guys have any ideas?

ok, i uninstalled the reinstalled Brave- that seemed to fix it.

( oh the vpn icon showed on my new profile window but it wasnt turned on)


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.