Not receiving ad rewards in Uphold account; support won't respond to emails

While this topic may have been raised before, I know it’s an ongoing issue, and I don’t see a lot of signs that anyone has been getting help with it.

Here is a summary of the problem on my end:

  1. Despite having a verified wallet, I have yet to receive any of my monthly BAT rewards for viewing ads.

  2. Despite reaching out to Brave Support several times (both via email at ads-payment-issues@brave.com and via direct message with a support person on this forum) with my wallet info, I have not received any help in terms of identifying or resolving the issue.

  3. As of several days ago, the rewards tally in my browser stopped updating altogether. It’s been stuck on the same amount (down to the last decimal) for at least three days.

  4. Uphold will not provide any support for Brave/BAT payment issues. Instead, they direct me to Brave Support … which doesn’t respond.

This is demoralizing. I don’t see how you can have a “community” when you promise people money and then don’t pay them and don’t answer their questions about why they aren’t getting paid.

And I know that my case is not an isolated issue.


What Operating System and Brave version are you using (Menu --> About Brave)?

Mac 10.14.6
Brave Version 1.26.77 Chromium: 91.0.4472.164 (Official Build) (x86_64)

Is your browser wallet currently verified? (yes/no)

YES

What date did you verify your wallet?

May 11, 2021

Have you been able to successfully receive payments in the past?

NO

Are you using a VPN? (yes/no)

NO

Are you in a supported region (see here for list of supported regions)?

YES

Does your device pass the SafteyNet check (Android only)?

NOT APPLICABLE

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??

It’s off. I never turned it on.

1 Like

How many BATs do you have accumulated in your Browser Wallet? Like this one:

image

Thanks for your reply. That one is showing zero, but my pending rewards are above zero. Just wondering why they aren’t being deposited into my Uphold account.
.
Screen Shot 2021-07-27 at 3.37.54 PM
Screen Shot 2021-07-27 at 4.10.16 PM

Did this value ever go above 0?

Good report.

Latest Brave Browser desktop version update was yesterday, July 27, 2021:

1.27.109

Initially it did, when I deposited 15 BAT in order to verify my account. I eventually moved those funds back out, though. Otherwise it has not gone above 0.

Ohh this looks like a completely new thing, I haven’t seen it before…

@GreenBananaPorridge Looks into this issue, he hasn’t received any payments since the beginning.

1 Like

Thanks for following up. I had already given my info to Mr. Green Banana Porridge, after he told me to send a DM in response to a forum post I made.

Well, I sent the info and then he never replied.

He takes a few days to reply.

He gets hundreds of DMs daily, so just wait.

They need to get him some help.

As I mentioned, I have also sent an email to the support address, and I haven’t gotten a single reply in almost three weeks.

I do appreciate your replies, but it’s unfair to say “just wait” when I’ve been doing that for almost a month with no success. :frowning:

The mails are not very useful, just wait for him to reply.

He usually doesn’t reply when he is offline, he is the most active guy here, and if he doesn’t reply to you then the others will take a lot longer to reply.

So, as I said just wait, you have waited for 1 month, you can wait for 1-2 more days.

I have waited 1-2 more days and am still not any closer to a resolution than I was a month ago.

Are you affiliated with Brave? If not, why are you making excuses for them? They’re withholding funds that they owe me, and based on the forums, they owe a lot of other people, too. The lack of transparency should be alarming to anyone involved in this project.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.