Half of the rewards received but not sent to UPHOLD

What Operating System and Brave version are you using ?
Version 1.24.85 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no) yes

What date did you verify your wallet? I’m not sure but I think it was in February 2020, I have received ad rewards for the first time in April 2020

Have you been able to successfully receive payments in the past? YES

Are you using a VPN? (yes/no) no (I used once or twice for short periods of time)

Are you in a supported region? Yes (Portugal)

Have you manually turned off Auto-contribute on all of your devices linked to Uphold?? Yes

I have received BATs every month but I haven’t received last month payment yet. I know this is a common issue now, but I don’t know what to do now.
As you can see in the images, it says I received 2.5 BAT (even though I had more than 4 BAT) May 11 but I didn’t receive anything in my Uphold account and my Estimated Earnings reseted to close to around 0.4BAT.

it seems to me that your uphold account got disconnected from your wallet before the May payment otherwise it shouldn’t be recorded in the wallet activity.

I don’t think so, because there is an option called “Disconnect from Brave Rewards”. Anyway is there a way to recover my BATs ?

Not too sure; try disconnecting Uphold, donating the rewards, and reconnect.

What do you mean with donating the rewards? If I disconnect do I lose something, do I get penalized in the next month payment? (IF I GET PAID)

Ok, I think I get it. You should just send it to Uphold (withdraw funds) and it should work.