Navy Federal Credit Union 2 Step Verification won't Remember Browser

Description of the issue:
When I login to the Navy Federal Credit Union website, it requires a 2-step verification process. There is a “remember this browser” checkbox to prevent the user from having to do this each time, but it requires the 2-step everytime. This works fine with Safari.

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no). yes

Does the site function as expected when Shields are turned off?
Each time you login to the server and do the 2-step verification, it uses a different server, so it doesn’t work to turn off the shields for a particular server.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):. I have tried shields down and it work due to the previous question’s answer.

Does the site work as expected when using Chrome?.

Brave version (check About Brave):

Version 1.46.140 Chromium: 108.0.5359.99 (Official Build) (arm64)

1 Like

Hello there @theMotoMan please accept my apologies for this issue. Could you please try opening your main profile in private or guest mode to see if the 2FA is no longer prompted If you are not requested to enter it again, try disabling your extensions to see if this is the cause of the issue.

You can open a Guest Window by going to Main menu --> Open Guest window:

  1. On your computer, open Brave.
  2. At the top right, click Menu → More tools → Extensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

1 Like

I cleared all history, images, and cookies, removed all the extensions and it worked. It also worked in the guest window. So I am not sure which part actually fixed the problem.

1 Like

@theMotoMan Glad to hear. Most likely it was/is one of your extensions. If you add them back, chances are you’ll experience problem again. If so, can report to the extension’s developer you had the issue and they might be able to make modifications. That’s assuming it’s an extension you want/need to use.

At least glad to hear Kevin got you squared away and you’re not having issues now.

1 Like

Glad to read that @theMotoMan. As @Saoiray stated it’s a possibility that an extension was causing this error, you can try enabling the extensions you had one by one to see if the issue persist when one of those extensions is enabled.

If you have other concerns, please let us know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.