Financial Institution Logon failure using new 2FA verification site

Here’s my experience:

  • I haven’t been able to successfully logon to my bank for some # of weeks
  • The bank seems to be using a new 2FA verification service at
  • The bank links to that page immediately after UN/PW logon but the page doesn’t load. A blank page is presented with no errors or helpful information
  • I successfully logged on using the bank’s new 2FA page with Brave on a laptop that I haven’t updated for some time, Brave browser ver 1.49.132 Chromium: 111.0.5563.147 (Official Build) (64-bit)
  • The Brave browser ver on my almost always up-to-date desktop that could not logon using new 2FA site: 1.51.110 Chromium: 113.0.5672.77 (Official Build) (64-bit)
  • I tried deleting all cookies on the failing computer, no change
  • The OS on both computers is Fedora 37.

Since Brave is being constantly updated and my bank appears to have made a recent change to the 2FA verification service they use, I’ve no idea where the root cause of the ‘problem’ I’m having with 2FA logons resides, so I’m not blaming, just providing info.

I saw a related topic in this community asking for help completing transactions with a financial institution, and a response suggested trying the same from a new private window. The topic died at that point, but I gave the suggestion a try with my most up-to-date system, and that worked for me.

I’m presenting this experience for info but welcome thoughts on why this is happening and whether banking from a new private window is to be the new process - until it breaks - or has always been a good thing to do that I hadn’t heard before.

Thanks for your time,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.