Muting sound on tab incorrect behavior

Description of the issue:
There’s an issie with muting a tab, that is related to just clicking the speaker symbol on the tab when it’s playing sound. It seems to not reflect on the mute function of the tab available in the context menu and can be frustrating when you have a pinned tab that’s playing sound. In a pinned tab - the whole tab space be taken up by the speaker symbol, and you try to desperately avoid muting it when clicking it. But then if you mute it, and try to unmute it, it can become quite complicated to do so, unless you unpin it and then unmute, and then pin it back.
At the same time, there’s a mute tab option in the context menu for the tab, but it is not affected by this “speaker-clicking” mute function. I.e. it still shows you Mute Tab, instead of Unmute Tab. Seems they’re unrelated or don’t see the tab state change from one another.
All of this leads to a lot of frustration.

How can this issue be reproduced?

  1. Start playing some sound in a tab (e.g. YouTube)
  2. Pin the tab
  3. Click in the middle of the tab (on the speaker symbol)
  4. Tab should go mute
  5. Right click the tab, and note that there’s still option to Mute Tab
  6. It can be hard to hit the speaker symbol just right to unmute it, so it usually requires you to unpin the tab, click the speaker symbol (unmute), and pin it back. (And rewing the video to hear whatever it was that you’ve missed during this process)

Expected result:
At the very least, it’d be nice for that Speaker Symbol and Mute/Unmute context menu to affect each other. I.e. if tab is muted via speaker symbol - the context menu allows to quickly unmute.
But I think it needs some rethinking on how the speaker symbol shortcut works on pinned tabs.

Brave Version:
Version 1.38.117 Chromium: 101.0.4951.67 64bit

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.