Mute tab broken for pinned tabs

Description of the issue:
Muting a pinned tab is way too easy to do accidentally. This would be merely an annoyance, not a bug, but for the fact that unmuting a pinned tab is weirdly broken. I usually have to click the mute icon ~10x, pause and unpause the audio, and sacrifice a goat to get it to unmute.

How can this issue be reproduced?

  1. Pin a tab
  2. Play something in that tab
  3. Try to click that tab a few times, you’ll see it.

Expected result:
It would be nice not to accidentally mute tabs, but it’d be real nice to be able to unmute them once you do

Brave Version( check About Brave):

Version 1.37.116 Chromium: 100.0.4896.127 (Official Build) (arm64)

Additional Information:

Works as a workaround to unmute the tab. Conflicts with metamask’s shortcut though so you’ll have to go in and set a different one if you have metamask installed.

2 Likes

Also having this incredibly annoying issue.

My solution for fixing it has just been closing the tab with ctr+w and then restoring the tab with ctrl+shift+t.

Interestingly, when you accidentally click and mute a pinned tab, when you right click it’s as if the tab doesn’t realize it’s muted and just offers you the option to mute again.