Mute / Unmute Pinned Tab is Difficult/Annoying


I’m not sure if this is a chromium issue or specifically Brave related… but …
Its really annoying to manage the mute/unmute of a pinned tab. Because when you pin a tab it minimizes the size of the tab to just an icon. That’s great…
But when a tab is making noise, (specifically I always have trouble with Messenger tab.) The site favicon is replaced by a mute/unmute toggle while the tab is playing sound. When I click over to see the message I ALWAYS end up muting the tab unintentionally… further making this frustrating is that the sound icon is only there for a few seconds, so it’s very difficult to catch it and unmute the tab. There is no unmute tab option in the sub (right click) menu, only a mute option. (Even when the tab is muted, strangely. The submenu option does not change to “Unmute” when the tab is muted by the sound icon toggle.)

How can this issue be reproduced?

  1. Pin a tab that plays audio regularly. Preferably a messnger site so that the sound icon is only momentarily available.
  2. Click to the tab to check an incoming message. Accidentally mute the tab because the sound/mute icon is displayed while the sound is happening. The sound icon then disappears.
  3. Throw something because now you can’t unmute the tab until sound plays again.

Expected result:
Be able to unmute the tab easily, without having to rely on the sound icon to return. Either by:

  • Disabling the sound icon mute toggle for pinned tabs. (This is the best option in my opinion, since I can still mute/unmute the tab from right-click submenu).
    or:
  • Changing the right-click submenu option to “unmute” when the tab is muted by the sound icon toggle. I think that this doesn’t change to “unmute” when the tab is muted is probably a bug.

Brave Version( check About Brave):
Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

Additional Information:
Better yet, remove the mute/unmute toggle from the pinned tab altogether (Leave it on the regular because that’s not an issue) and put the mute/unmute toggle in the submenu (right click menu)

3 Likes

I’d like to second this request. My work uses Google Hangouts for messaging, which means I am constantly accidentally muting my gmail tab when trying to switch over to it upon receiving a message.

@aaronm @KingDingbat,
I feel your pain as I, too, have done this several times. It’s certainly an issue with the Chromium engine itself. I can’t say that we will get this particular annoyance fixed any time soon but I will open an issue for it.
In the interim, you can use numbered keyboard shortcuts to jump to the pinned tab without having to click on it directly. For example, on macOS – I can do fn + cmd + [number of tab, rtl] to jump to any open tab. So pressing fn + cmd + 1 will jump me to the pinned tab in the image below: