Unable to mute pinned tabs

Description of the issue:
The reason I switched from Chrome to Brave was because Google stupidly removed the ability to mute tabs, which is a feature I use daily. While I’m working I have a Youtube playlist that I play in a pinned tab, and up until recently (possibly the last update) I was able to click on the speaker icon of that Brave tab to mute it. Truthfully that was a little annoying because I’d often mute the tab when I actually wanted to switch to it, but now that it’s gone I’m very disappointed and I really want it back. It’s still possible to mute unpinned tabs by clicking the speaker, but once the tab is pinned it no longer works that way.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Open a new tab and navigate to any website that allows for playing continuous media with audio, such as Spotify or Youtube
  2. Play some media on that website and confirm that sound is coming through your speakers
  3. Click on the speaker icon to the right of the tab name and confirm that the audio no longer comes through your speakers
  4. Unmute the tab by clicking on the same speaker icon again
  5. Right click the tab and click “Pin” from the context menu
  6. Attempt to mute the tab in the same manner, clicking on the speaker icon of the pinned tab. Note that this is not possible

Actual Result (gifs and screenshots are welcome!):
Clicking anywhere on the speaker icon simply switches to the pinned tab

Expected result:
Clicking directly on the speaker icon should mute the tab

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

MacOS Catalina, Brave 1.3.115

Additional Information:
It’s possible that you intentionally disabled the feature because of how likely it was to mute the tab unintentionally. If that’s the case, consider this a feature request to please add “Mute tab” to the right-click context menu so that it’s once again possible to mute pinned tabs

While it may be the case that you can’t click on the speaker icon to mute the pinned tab, you can right-click the pinned tab and select Mute tab from the context menu:

There is no Mute tab option, there’s only Mute site, which is not what I want in some cases. As I said, I have a Youtube music playlist pinned and continually playing music, but sometimes I want to temporarily open another tab in Youtube real quick to watch a different video and it’s way easier to just mute the tab than it is to switch to it, mute the thing inside of it, then switch back. Truthfully it’d be nice if there was an option to just change that context option to mute the tab instead, because I almost never “Mute site” and just mute the tab instead.

Regardless though, the feature as I described it in the original post was definitely working for me last week.

Thanks for clarifying. I do see this same behavior on my end as well. While I do understand your frustration, at this time, the Mute tab option will not be available from the context menu. However, if you feel strongly, I’d highly suggest leaving a Feature Request here on Community for the devs to see.

I understand that it’s not available in the context menu. You still haven’t responded to the original question though: is it intended behaviour that users can no longer mute pinned tabs by left clicking directly on the speaker icon? As I said, the feature was working for me very recently and now, after updating to the newest version, it is not. If it was an intended change, can you please provide a link to the release notes that documented the change?


This is the intended behavior. I believe the issue many users had was not being able to (or having a lot of difficulty with) selecting the tab vs muting it when it was pinned, which is why we altered it.

This is unfortunate I used this functionality a lot. Anyway to toggle this back if we like it how it was or…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.