Login data disappears after update


Description of the issue:

Website login data appears to be deleted after manually upgrading to new versions of Brave

How can this issue be reproduced?

  1. Simply clicking on the update button in the Brave browser
  2. After the restart, all saved logins on websites have to be reentered

Expected result:
Login data should be retained between upgrades, especially when, as recently, there seems to be a new update almost daily.

Brave Version( check About Brave):
Version 1.45.118 Chromium: 107.0.5304.91 (Official Build) (arm64)

Hello @SteveH

Thanks for bringing this to our attention and sorry to hear you’re having trouble with Brave. Could you kindly share the following:

  1. Device(s) OS version.
  2. A screenshot of the issue.

Be waiting for your response and have a great day!

Hi Alice,

This is on a MacBook Pro with macOS 12.6.1.

I’m not sure that a screenshot would help. It’s simply a case of having to log in again on all web pages that require a password following an update to Brave.

I’m currently on Brave Version 1.45.123 Chromium: 107.0.5304.110 (Official Build) (arm64). I can tell you that the problem has persisted over the past several updates, which seem to be coming a lot more often than previously.

There is currently an update waiting, as indicated by the yellow Update button in the upper right corner of the browser. I haven’t done that yet so if there is something particular that I can screenshot for you, please let me know.

Regards,

Steve

Hey @SteveH

Thanks for your reply we appreciate the details. Can you confirm that you’re not on a separate/different profile from your main profile somehow? Additionally, are you using any extensions at this time?

Be waiting for your response!

Hi Alice,

To be honest, I never set up a profile. I think I was always on the default profile. Under the “People” menu, I still have just ‘Person 1’.

The only extension I have installed is 1Password password manager.

Regards,

Steve

Hey @SteveH

If you go to your user data folder (~/AppData/Local/BraveSoftware/Brave-browser/User data/Default ), do you see a Bookmarks file here?

Be waiting for your response!

Hi Alice,

I don’t see that folder at all.

I found BraveSoftware/Brave-Browser in Library/Application Support but I still don’t see a User data folder.

I’m on a Mac and I’m wondering if that’s a Windows path you sent me?

Regards,

Steve