Location Services are wrong

Following on from these threads here and here. The location services are still not fixed.
It only happens on Brave… Chrome, Edge, etc all return the correct location for me, but Brave puts me in the other end of the country.

Happy to provide logs or anything required, but as this has been reported a couple of times, can this please be looked in to?

EDIT:

Description of the issue:
When using any website which uses location services (such as google maps), the location services are incorrect.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go to https://www.google.co.uk/maps
Click on “Location” Target

Actual Result (gifs and screenshots are welcome!):
Taken to the wrong part of the country as assumed location.

Expected result:
Taken to the correct part of the country.

Reproduces how often:
Every time

Brave Version(about:brave):
Version 1.7.92 Chromium: 80.0.3987.163 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes

1 Like

@Tunes,l
I understand that it’s been reported before, but can you please provide us with as much information surrounding the issue and your setup as possible so that we can provide the most accurate support? You can see a template of the information we need here:

Apologies - have updated original post

@kiero / @An32sd5 Are you all still getting this issue as well?

and @animesh303 - Do you still have this issue?

Just did a search and have also seen that @Jeff_not_in_NC (Incorrect location in google maps) and @floridakiwi (Location reported incorrectly) have also reported this as issues recently.

But their tickets were automatically closed because it appears no one is looking in to this?

My two cents on the issue:

While investigating (i.e. Googling for IP based location services), I stumbled upon https://www.iplocation.net/ , which shows three different services - and three different locations. For me, the most recent and closest location is shown on ipinfo.io - the other two show exactly same date (2020-4-1), but completely different locations.

I’m having the same issues as described in the original post, BTW.

I have exactly the same issue, the iplocation website says I am about 400km away, and google maps cannot accurately gather my location as a result.

Also, tried today with Brave Dev [Version 1.9.44 Chromium: 81.0.4044.122 (Official Build) dev (64-bit)], with same results as on my regular one.

The odd part is this: when I first open Google Maps, it shows my rough location being in the correct neighbourhood (within less than a kilometre where I reside). Only when I request for precise location, things go way off. Same happens with Bing Maps as well.

Yup. mine is the same… when opening google maps it puts me in the rough neighbourhood… but after requesting location services, it sends me over the other side of the country!

Also with your link above, all 3 of the locations given were nowhere near where I am, but as with you… ipinfo.io was the closest (although not very close at all).

I have the same problem. In my case, according to https://www.iplocation.net/ the results from IP2Location and ipinfo.io are wrong (about 600Km away). The result from DB-IP is not exact, but it’s more accurate (12Km away).
When I visit Google Maps I see the position from ipinfo.io

+1, seeing location issues as well on Mac OS X (10.15.4). Other apps have exact location (even though my IP shows as being somewhere else), but Brave seems to be locked to a location I manually navigated to via coordinates in Google Maps a few days ago. I noticed that Brave doesn’t show in OS X’s list of apps with location permissions. Is there a chance it doesn’t have OS level access to location?

I have the same problem after migrating from one Mac to another. I initally had the problem in all applications, but I discovered that System preferences -> Privacy -> Location services was disabled.

After enabling it, I now get the correct location in all other browsers as well as the built-in “Maps” app in macOS. However, Brave still doesn’t get it right in any of the location-based sites I’ve tried, and I can’t seem to manually add Brave to the list of apps in System preferences -> Privacy -> Location services either.

Me too.
In case it matters… none of the locations on https://www.iplocation.net/
are correct either.

And Brave always puts me near Newcastle when I am in Sydney! (200km away)

Does not happen on vanilla Chrome.

Same issue. Brave is using my ISP location. Chrome does not. When I open Google Maps on each browser, Chrome is correct, Brave puts me in Minneapolis which is the Sprint POP I’m connected to. Can’t use Brave until this issue is fixed.

Same problem here. Location accurate in Chrome and Edge but 40 miles off in Brave, location is in the countryside miles from anywhere so not ISP location.

Same issue, currently in morocco.

When i first noticed the issue i checked chrome browser. It was sending me to the same wrong location too. In location settings i removed googlmaps from the ‘allow’ list. When it asked me to know my location again, it sent me back to the correct place.

Trying the same method in brave does not work, nor does clearing cache, cookies etc…

Interestingly, the 4 different gps coordinates i get on https://www.iplocation.net/ip-lookup are wrong.
IP2Location is close to me, only a few km off.
ipinfo.io is closest to the location brave sends me to, a few km off as well.

None of the coordinates from iplocation are the one that brave sends me to in googlmaps.

If anyone has more ideas, please share!

Also wanted to add that this issue still exists in the current version of Brave.
Version 1.9.80 Chromium: 81.0.4044.138 (Official Build) (64-bit)

Issue persists in V1.9.80. Machine Location Services enabled. IP trace location showing different location (other end of the country) to that returning in Brave. Issue is persistent regardless of requesting service - tested Google and Weather.com services.

Updated to V1.10.97, the problem persists. There wasn’t anything in the release notes, so didn’t have too high hopes.