Location service is wrong for months now

I see a lot of issues on the community platform but never a solution.

Bave is continuously giving bad location on websites like “the weather channel”, “google map” or whatever the website asking for position.
It detect me 900km away…

The location service works well with Google Chrome or Firefox.

See

Is there anyone taking care of this ?

Version 1.35.103 Chromium: 98.0.4758.102 (Build officiel) (64 bits)

Thanks.

@Metal3d It’s all confusing and I’d like to find out what ISP everyone is using, if anyone is using VPN, etc. I don’t feel like sorting through all the links you gave since some are 2 years old and all. I know in one, it looks like a Github was going but I don’t know how to track status of those things.

What I can say is a lot of people aren’t really having that issue. If nothing else, I had to help someone not long ago with the opposite issue…that their exact location was showing when they didn’t want it to be. Stop Google location - #2 by Saoiray

It is also odd though that you say it works well with Chrome and Firefox. I mean, if you’re logged into Google through Chrome, it would know your location better through its own settings and all. Not sure about Firefox.

Random thing here Metal3d… if you go to brave://rewards-internals and then click on Ad diagnostics does it show you at your proper locale?

1 Like

After years of using Brave and having this issue, constant location in another city, I looked if there was a solution for that and founds this thread saying it is still around.

I don’t know if it will help you, but yesterday I was able to correct my problem by changing Windows 10 settings. In Privacy settings, I change location to ON for “Allow access to location on this device” and change also to ON for “Allow apps access your location”.

This solved the problem, turns out I should have looked better before setting my privacy settings.

My ISP is Orange in France. I’m not using any VPN and this problem doesn’t happen on others browsers.
This problem is present on all my computers, whatever the Linux version I use on Brave only.
If these issues are sometimes 2 years old… That simply because this problem exists for years :wink:

I will check the diagnostic in a couple of minutes.

OK so,
Firefox - google connected to my account:

Very accurate, I blurred the picture of my wife who shares position with me…

Now on Brave:
image
look at the blue point, near “Grenoble” on the East, 800km far away from me.

The same session account, the position taken at the same time.

In brave://rewards-internals/ =>


Ads enabled: true
Locale: fr_FR.UTF-8
Catalog ID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Catalog last updated: 20/02/2022 16:23:53
Last unidle timestamp: 20/02/2022 16:27:13

I don’t have any other information to give you but Brave is wrong on my position… and this for months (or years…)

Jus to be sure:
I disconnected all my account, and I tried the position requests from OpenStreeMap.
The result is exactly the same than with google map. Brave thinks I’m in a city where I never went. Firefox gives a very accurate position.

Ok, I know I could toss out a million things but would all be blind guesses. Staff should start coming back tomorrow. I’m not sure which person would be best to help but I am gonna try to tag @Mattches, @SaltyBanana, and @fanboynz as should be able to help or tag in the person who might know better if they can’t.

@Metal3d,
Can you try testing the behavior with Shields turned off for the maps site you’re using? Additionally — just to be sure — did you already grant the site permission to detect your location (you can check by clicking the “lock” icon in the address bar while on the site, and viewing which permissions have been granted)?

Hello,

I tried without shield, and yes of course I granted permission:

The popup on the top right says “Position access allowed”

And the point on the map is not my real position, I’m 800km away on the NW.

EDIT: here what gives Firefox, the detected position is near prefect:

1 Like

Just in case of you ask, I don’t have any override:

Can you test in a clean Brave beta build, no extensions, no VPN. I just tested the following sites:

https://mylocation.org/ (IP based, Location incorrect)
https://www.gps-coordinates.net/my-location (Geo location, Location correct)
https://my-location.org/ (Geo location, Location correct)
https://gps-coordinates.org/my-location.php (Geo location, Location correct)
https://www.maps.ie/coordinates.html (Geo location, Location correct)
https://www.where-am-i.net/ (Geo location, Location correct)

The only one that didn’t get the correct location was the mylocation.org since it just used an IP address only.

1 Like

(post deleted by author)

(post deleted by author)

Beta installed

I made a mistake: IP location is the same in beta and stable => Laval, 12km away (it’s normal so)
Geolocation gives the same: Paris, 400km away
So… Beta doesn’t fix the problem

I’m pretty interested in this topic as well. I am a Linux user and this is a constant annoyance for me. Google maps has me consistently about 30 miles away from my house. I can have Brave and Firefox open at the same time and both will show me at different places.

Manjaro Linux

Brave Version 1.36.111 Chromium: 99.0.4844.51 (Official Build) unknown (64-bit)

No VPN

What I will try is to install a Windows VM or launch Brave with wine. That can eliminate some tracks about the OS.
If the problem disappears with Windows version, so the problem is about the Linux build. If not, so the problem is about Brave with provider or something like this.

Beta version doesn’t fix the problem.

PS : brave on Android is OK as it used GPS to find my location

Version 1.37.113 Chromium: 100.0.4896.88 (Official version) (64 bit)

I have had the same problem for several years. I use opensuse tumbleweed (Linux) and it has a pretty bleeding edge version of brave. I created a new user and tested all the links above to check geoloc and geoip. Geoloc is 500 km wrong. One thing that strikes me is that geoloc and geoip are very close to each other. About 20 km apart.

“This topic will close a month after the last reply.”

I created an account to not let this topic close.
No solution yet

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.