Just updated and lost your bookmarks? A (long-shot) solution here

windows

#1

System: Windows 7
Brave: 0.25.2 (I think…)
Upgrading to: No idea.

I’m posting this in the off chance someone encounters the same issue and can get some help.

For a couple days now, Brave has been bugging me with update issues. The auto updater just kept launching and crashing. :face_with_raised_eyebrow: So I thought, since the auto-updater can’t cut it, I’ll just download the latest and put and end to this.

Imagine my shock when opening the new shiny Brave version to:

  1. no open tabs (extremely annoying)
  2. NO BOOKMARKS (enough to nuke Brave off every device I own :rage: :rage: )

However, I found that I could drop by:

C:\Users<your username here>\AppData\Local\brave

(For windows newbies, this folder can be invisible. You’ll need to turn on invisible files. For Win7 anyway.)

Here I found the old Brave under the app-.0.25.2 folder. There’s an .exe in there which thankfully still opened and I again had access to my tabs, bookmarks, and passwords. Which I am presently exporting and saving all the tabs. (But I’m still mad about it. :face_with_symbols_over_mouth: )

Here’s hoping somebody else can find this and -not- end up nuking Brave off of everything you own. :wink:

Funny thing is, as a test for SCIENCE, I tried doing the same thing with Firefox. Downloaded a fresh installer, and installed the latest. (My Firefox is old too.) All bookmarks present. History and everything. No issues.

Of course Firefox is less-than exemplary so I went back to Brave. :sweat_smile:

EDIT: Turns out this may have been expected behavior. If I’ve read things correctly, even had the update worked I would have needed to import my old Brave data to new Brave. Curiously however, new Brave couldn’t locate old Brave when trying to import bookmarks anyway. I had to use my exported version. That one I can’t figure. Old Brave was still in the registry. Should have had no issues finding it. :upside_down_face:


#2

This topic was automatically closed after 30 days. New replies are no longer allowed.