Inline pop-up in login forms still show when "offer to save passwords" is disabled

I use a third party Password Manager (1Password), but every time I try to log in to a website I still get the black inline pop-up suggesting me a username.
Since the pop-up is floating above the 1Password username I can “guess” it is the correct one but this is still undesired behaviour. There is a reason I have disabled it :wink:

I have “Offer to save passwords” disabled on brave://settings/passwords

I’m running:

Brave is up to date
Version 1.7.98 Chromium: 81.0.4044.113 (Official Build) (64-bit)

Hi @Ronaldt,

Can you try going to brave://settings/clearBrowserData
Click on Advanced, and then clear any password/autofill data.

Hi Aa-ron, it says:

Passwords and other sign-in data

So there is nothing to clear (tried anyway of course).

Weird thing is, the username is actually correct and it’s only doing it on a couple of websites. It’s a little bit annoying but I can live with it, unless someone knows a way to fix it of course.

Can you try going to brave://settings/addresses and disable Save and fill addresses? And then try a site that has the pop up.

When I installed Brave I disabled both passwords and save addresses to be auto-filled.
Both have an empty “… will appear here” message underneath it.

Odd thing is that it does not happen every time, just every now and then. But also on websites I’ve never visited before.

When clicking the auto-suggested item, only that input field is filled. So your guess for it to be an address field (and not a username/password combo) sounds plausible. That would still be a bug, since login forms should not be autofilled with addresses. Plus, I have no addresses saved in Brave. There is no other form-data saved; the Clear Browsing Data pop-up says “Autofill form data: none”.

Like I said it only happens now and then, I’ve gotten used to pressing [esc] when it pops-up so it’s no really biggy. To me it does seem to be a bug though.

Next time you see the pop-up, can you select it with the arrow key, and use fn + shift + delete to remove it. And then see if it pops up in the future.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.