Autofill Stopped for One Site Only

Description: Autofill password stopped working on only one website.

I have a browser wallet on Tezos called Kukai. I need to sign for all crypto transactions, which requires a password. The password has been saved in my browser for more than a year and just stopped working. I used to click in the password box and it would autofill. Now that no longer happens. I’ve tried deleting it and re-saving the password on the site with no luck.

Now when I just click the password box it stays empty.

Expected result would be that it autofills in my saved passwords.

Happens now every time.

Mac 12.6.1 and Brave Version v1.45.123

It shows that there is a saved password for the site on the right side of the Address Bar next to the Brave Shields logo. So it’s recognizing that there is a saved password for that site, it’s just not autofilling. I do have Auto Sign In selected as well. Thanks in advance for the help.

Does disabling extensions help?

I only use 3 extensions. They were all disabled and it still doesn’t work.

Here is a screenshot of my browser. You can see in the address bar where it recognizes this as a saved site.

Not sure whats the case. Im gonna tag some people who are better equiped to help your case @rodrige @Aman_M @hub

1 Like

There are some more issues similarly- AutoFill not working for passwords anymore & After upgrading to 1.45.123 Brave won't popup saved passwords.

@bit Can you go to brave://settings/passwords and toggle both these Offer to save passwords & Auto Sign-in on and see if there is a difference? Do post an update.

I tried, no luck. It still doesn’t fill in.

Ok. Will have to tag @Mattches for more info.

Sounds good thank you! Not sure if it will help, but it is a pop-up password form with no username.

@bit Can you try to disable shields (from Brave lion icon) on that site and see if it works?

I’ve tried that, didn’t work unfortunately.

1 Like

Thanks for the update. Hopefully, someone from the support team will give an insight.

1 Like

Hope so, thanks again!

1 Like

@bit,
I see the issue here but I’m actually not sure whether or not this is a bug now or if it used to be a bug. Based on the screenshot, you’re not logging into this site, is that correct? It looks like this is a confirmation screen for a transaction being made.

In my mind, the browser should not offer to autofill this password for you, as it is not a login credential and requires that the person making the transaction actually knows the password — otherwise someone with access to your machine (or account, maybe) could make transactions without your consent. The password request is an extra layer of security.

When you go to login to your account on this site, is the password remembered?

Thanks for getting back to me. I have to use my password every time I approve a transaction. Until the latest update, Brave would always offer to autofill the password for me. It’s a very complex and long password, so that’s why it was always so nice when it would autofill when I’d click in the password box. It doesn’t remember my password when I logout and try to log back in.

The issue seems very similar to what’s going with this pop up password form -

1 Like

@bit,
Do you have the credentials saved in Brave or is it in a password manager?

The credentials are in Brave.

@bit,
Very strange — do other sites load stored credentials correctly or do they all behave this way?

Works like it should on every other site. Do you think it could have something to do with the pop up? There is no username field either so I wonder if it has something to do with that. If you can think of other sites with no usernames, I’d be happy to test to see if it works there. It worked fine until maybe 2 or 3 Brave updates ago.

It may be useful to test this behavior in a new profile and check to see if you get the same results. It does require that you copy your login credentials into the new browser profile, but if it works we can reasonably assume that the issue itself has to do with your main profile and not the browser itself.

Same issue unfortunately. Happens across different machines as well - both using the most current version of Brave.