How to get rid of "did you mean to go to" suggestions when the URL entered is valid?

bug
privacy
#1

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:
Not sure when this appeared as I am a recent user on windows but here is the problem: each time I type a valid domain name in the URL bar such as https://weeblr.com (same happens with or without the scheme), Brave does take me to the site but it thinks it knows better and opens a suggestions bar with “Did you mean to go to https://weebly.com”?

That bar is a big nuisance: it takes up screens space, can only be closed by actually clicking on the x sign which really is a pain and basically prevent using the browser for any demo or client work.

In addition:

  • why would this happen when the URL is valid and can be reached?
  • why would this happen when I disabled “Use a prediction service to help complete searches and URLs typed in the address bar”??

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Type https://weeblr.com in the URL bar and press enter.

Actual Result (gifs and screenshots are welcome!):
You get to the site but you also get this:
brave
Expected result:
You just get where you want to go and no painful banner is displayed.

Reproduces how often:
100%
Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 pro - Brave 0.61.52
Additional Information:

0 Likes

URL "Lookalike" suggestions appearing while browsing
#2

Hi again

As added information, this of course does not happen in Chrome.

Best regards

0 Likes

#3

This has just started happening to me also. Never happened before. I have autocomplete and all other options for storing/helping/autocorrecting disabled.

0 Likes

#4

I just responded to @jollyzilla’s post a moment ago. When testing this issue on my end, going to the site example given (vive.com) I saw the same suggestion when I landed on the site, but it only displayed once and after closing it, it would only appear again upon refresh.

That said, @shumishaWeebly.com does not display this message on my end.
I’ve reached out to the team for additional input. Thank you for your patience.

0 Likes

#5

Hi @Mattches

It’s not when you try weebly.com. it happens when you try weeblr.com. As weeblr.com is the less well-known and smaller site, the suggestion keeps offering the other option.

Any suggestion should stop and be removed automatically as soon as I hit Enter. Nothing should take up space in the viewport.

Thanks for following up, kinda big issue one I would not have expected to happen in a privacy concerned software.

Regards

1 Like

#6

Like @Mattches, I only get one notification, though it does happen on every page of the site (vive.com). MacOS 10.14.3, Brave 0.63.20 Chromium: 73.0.3683.75 (Official Build) dev (64-bit).

0 Likes

#7

@Mattches @hnktong Yes, vive.com is another example. Brave suggests to go to live.com instead.

Please how can this infuriating “feature” be disabled?

Best regards

0 Likes

#8

Working on it right now – I’m honestly not sure why it’s showing up now. I’ve never seen this before. I’ll try to make sure I come back and keep you updated on it.

0 Likes

#9

I have this issue too. I originally noticed it when visiting https://support.ring.com/hc/en-us. It suggests going to “bing.com”. I too can confirm that going to weeblr.com like the OP also has the same problem. I thought this was a malware or virus issue before finding this thread. @Mattches, you can disregard my previous PM. I’ll wait for a resolution through this thread.

0 Likes

#10

Must be this setting, right?
brave://flags/#enable-lookalike-url-navigation-suggestions

EDIT: Yes, disabling that preference prevents the suggestions from being displayed.

3 Likes

#11

@jek6094 Thanks, that fixed it for me. :slight_smile:

1 Like

closed #12
0 Likes

opened #13
0 Likes

#14
0 Likes

#15

I get this all the time on advcash.com, the browser suggests adcash.com. Quite a nuisance, and thanks for the info on how to disable this.

2 Likes