Google Hangouts

Google hangouts works with Google Chrome, Mozilla Firefox but not Brave. I’ve chosen the appropriate settings but it still won’t work. How can I resolve this problem?

Thank you.

@Sal can you give more info about your issue? Providing Brave version, OS, screenshot of the issue, etc, will be really helpful for support and troubleshooting.

Also, did you access it via or using Hangouts extension? And can you elaborate more about “appropriate settings”?


I’m using Brave, Version 0.63.55 Chromium: 74.0.3729.131 (Official Build) (32-bit and Windows 10. I accessed Google Hangouts through both the extension and the website. The video chat and phone call features don’t work. How can I send you a screenshot of a phone not ringing?

@Sal to upload attachment, you can copy/paste the image to post editor. Or use the Upload button.


When you’re on Hangouts website, can you try with:

  • Allow all device recognition and
  • 3rd party cookies blocked

via Brave icon at URL bar?
It’s per site shields settings and only affect Hangouts website.

For the extension, we receive similar report and will logged an issue (if there isn’t any).

Can you restate your instructions another way; I don’t understand what you wrote. Thank you.

I believe we have a known issue with the extension as I’ve had other users reporting it recently. I will try to find the filed issue for reference and link to it.

However, even in those cases, Hangouts functions work as intended on the website itself (or at least they should). Please try the following:

  1. Visit
  2. (assuminng you’re already logged in) Click on your Shields panel and change the Device Recognition setting to Allow all
  3. Allow the site to refresh.

You should now be able to make and receive calls. Note that you will also have to grant permissions to the site for it to access your camera and/or microphone. Please let me know if this resolves the issue for you.

Additionally, many web compatibility issues may be caused by Shields blocking unwanted and/or potentially malicious content. I would recommend thumbing through some of our Shields documentation to better understand how they work and improve your browsing experience.

1 Like

Using the same version as @Sal (Brave and Windows) to try to make a video call after logging in initially resulted in a call initiation screen that was black except for the control buttons with the camera activation light on, then doing the tweak to Device Recognition called up the image the camera was capturing, but in neither case would it initiate a call. Clicking “Invite People” and trying to send an invite did nothing.

Trying again in Nightly (Brave 0.67.11 Chromium 74.0.3729.131 (Official Build) nightly (64-bit) produced the same black screen, but I could initiate a call and see and hear the person on the other end. Doing the Device Recognition then enabled two-way communication. So it’s still a thing in the latest Nightly, apparently.

I’m now able to text and hear the other party via the phone call feature but I’m not heard on the other end. I’ve change the microphone settings but it still didn’t work. My headphone/mic has no problems working on hangouts via Chrome or Firefox, though.

@Sal, maybe click the settings icon/link in the call window and be sure the right microphone is selected? In a video call, there’s a gear in the upper right of the call window, illustrated in the lower part of my post in related thread Access to microphone on Google Hangouts.

I’ve tried all 3 microphone selections with no success.

A couple more suggestions for you:

  1. Try opening a Private or Private /w tor Window and attempt to initate a call via Are the results the same? Note that you’ll have to re-grant permissions and configure Shields appropriately since user settings don’t transfer into Private instances.

  2. If you’re willing, we can try a more nuclear option – First, visit hangouts website, click the lock icon --> Site Settings --> Reset all Permissions. Now, navigate to Settings --> Advanced --> Privacy/Security --> Site Settings --> View Permissions and data stored across sites, use the search to find any/call hangouts site data (note that a search for “Hangouts” will probably be fine but there’s a chance you may need to clear all Google account data as well).
    Once complete, close/relaunch Brave and visit the hangouts website again and configure the site to allow audio recording, microphone use, Device Recognition = disabled, etc. (note, I believe “autoplay” may also need to be enabled but unsure).

Let me know what shakes out.

I tried both possible solutions with no success.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.