Hangouts meet : micro doesn't work EVEN with Shield down

Hi,

I’m using Brave 1.5.115
under linux (archlinux)

I’m using successfully ‘google meet’ with Chromium and Chrome

I’m facing same kind of errors as reported here last year for instance
(Google Hangouts)

I’ve set “shields” down, or else the meet wouldn’t even start.

I’ve tried to reset access settings, tick / untick “Uses Hangouts component to enable screen sharing and other features in the browser.” settings … nothing works.

One interesting thing though :
When trying the “test” sound in meet, the “mic” symbol is activated also.

It’s AS IF there was a weird mixup between Mic and Speaker.

With exactly same OS settings, chromium works.

Additional info
Just tried again with a friend,
When sound comes from him, I can see my hangouts ‘vu-meter’ like mike icon moving.
But when I speak => nothing.

It’s really as if micro was recording the wrong device. (once again, with exactly the same settings, chromium works)

Additional info

tried with a usb camera/micro => works fine !

so … it’s an intenral mike support mixed up, no idea how this could happen but at least i have a workaround