No Audio with Google Hangouts or Hangouts Meet

Description of the issue:
I can hear audio from sites like YouTube, Etc, but when I create a call on Hangouts, or Hangouts Meet, or with the Hangouts Extension in Brave, I get no audio. I can choose various Audio Out options, and click to ‘test’ sound, but I get no audio out.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Open Hangouts.google.com, make a call, no audio.
Open https://meet.google.com/_meet and start a call, “Join or Start a Meeting” and the same problem. No audio, I can select between various audio out options, but none of them work.

I tried doing this with shields up and shields down. No impact on audio.

Actual Result (gifs and screenshots are welcome!):
Actual result is difficult because no screenshot between working and non working audio… It looks the same!

Expected result:
I should hear some audio! :slight_smile:

Reproduces how often:
EVERY TIME.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Pro. Insider Preview 10.0.19013.1122
Realtek Audio
Version 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit)
Additional Information:

Same issue, came here to report it.

Important to note that VIDEO (webcam) WORKS but there’s no audio output to my ears. Can’t hear anything. BUT, the person I called told me later they could both hear and see me.

  • Confirmed Hangouts was set to use the correct devices for input/output.
  • Confirmed Hangouts in Google Chrome works as expected.

I simply cannot use Brave until Hangouts works. It’s my primary phone number and I use it primarily through Google Chrome.

Hi @ChesterCheeser and @DerPerlin, thanks for taking the time to write in. This is a known bug and the current work around is to disable Shields. If you’re interested you can track some of the related issues here:


Let me know if there’s anything else I can help to answer in the meantime!

@steeven, I had already tried disabling Shields on hangouts.google.com before coming here to report the issue.

Is that the only workaround?

The second link you provided says at the bottom: "The issue does not resolve when disabling Brave shields."

Thanks @ChesterCheeser, what OS and Brave version are you running? Release build?

@steeven

Brave Version 1.0.0 Release Build Chromium: 78.0.3904.97 (Official Build) (64-bit)

Windows 10 Professional Version 1909 (OS Build 18363.476)

I should mention, the links you provided are not about this issue. They were about Hangouts being blocked altogether in Brave. Disabling Shields fixes a few issues but doesn’t do enough to enable Hangouts to work correctly.

Disabling shields does nothing with this audio issue. My microphone works, and my webcam works, Everything works except for my ability to hear others.

1 Like

Sorry for the delay here. @DerPerlin are you also on Windows 10 Professional and Brave 1.0.0?

Same issue for me … Shields off still no audio for meet/hangouts …Back to chrome for now i guess … Brave 1.0 on Windows 10 Home 1809

EDIT: SOLVED … Autoplay was the culprit for me. In the address bar click the autoplay icon (circle with a traingle) and select “Always Allow”. Refresh and sound works now.

Yup, Brave 1.0.0 and Win 10

@ChesterCheeser does enabling auto-play do the trick for you?

Hi @steeven manually enabling auto-play did fix the Hangouts web site issue! But the Hangouts Chrome extension still doesn’t work (it shows an empty drop-down for both the Microphone and Speaker setting).

From the :point_up: link:

After a few hours, I found it was the third party cookies preventing it from working. To see this in action, I allowed third party cookies, removed the extension, added it from the Chrome Store, and was able to make a call as well as see the microphone and speakers. Went back to settings and blocked third party cookies, removed the extension, added it back and was back at square one with hangouts failing to connect.

I tried that but it’s a no-go. Granted, he was on Linux and talking about Google Chrome.

So far, I’ve tried manually enabling every relevant ‘Site Setting’ in Brave for hangouts.google.com, meet.google.com, and voice.google.com, as well as whitelisting Google’s cookies as that post suggested. Still the Hangouts extension in Brave shows those empty drop-downs, resulting in no audio in either direction. I don’t think calls even connect.

Screenshot_195

@ChesterCheeser,
Can you ensure that the Hangouts extension toggle is set to “ON” in Settings?

@Mattches, yes that’s enabled for me:

@ChesterCheeser,
So we do have an issue logged for this already:


I’ve added your report to the Github thread for the devs to review. It’s marked as P2 so we should see some movement on this issue soon. Sorry for the inconvenience and we appreciate your patience.

Manually enabling auto-play fixed this for me, both in the browser and in the extension.

1 Like

Are you on Windows 10, @DerPerlin?

My device info is in the op.

has any progress been made on this? I use hangouts extension for phone access and it’s the only thing that’s preventing me from use brave as my daily browser.

what auto-play settings did you set to allow? just hangouts.google.com ?