First searches take long to load on browser startup

Description of the issue:
After I launch the Brave browser, then search for something, it takes almost more than 1 minute to load the search results/website (if I entered a URL). This only happens to the first search I do right after launching the browser. All searches after the first one load fine. (It cant be my internet connection since it averages around 150-200Mbit/s)

Ive tried turning off/changing settings like Hardware acceleration (which I turned off after install), P3A (which was off for me by default), Automatically send pings to brave (which I turned off after install) and DNS settings (which was left at default) but nothing seemed to help. Then i stumbled upon a setting called “Upgrade connections to HTTPS” and changed that from strict to standard. At first I thought this seemed to have helped a bit, but when I tried to search for something the next day it was slow again. When I checked the settings again, this option was set back to strict for some reason (Every time i change any setting in the category where this is located, it changes back to what it was before after relaunching the browser. Im pretty sure this is a bug…).

Ive only installed 2 extentions. Bitwarden and uBlock Origin (adblocker). Ive tried disabling the adblocker entirely but the issue persisted.

Ive read online that other people are having the same problem, but never found a clear solution to the issue so i was hoping to find it with this post!

Thank you in advance!

How can this issue be reproduced?
(Im not sure if this issue is reproduceable for other people…)

  1. launch brave browser
  2. Search for something/enter a URL
  3. wait for almost a minute and get your search results/website

Brave Version( check About Brave):
Version 1.60.125 Chromium: 119.0.6045.199 (Official Build) (64-bit)

Additional Information:
Im not entirely sure but this seemed to have started occurring after about 1 or 2 browser updates ago.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.